Cookie Manager: block sites from Stored Cookie tab

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
18 years ago
10 years ago

People

(Reporter: gabriel, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I think it would be great if you could right click on a cookie in the cookie
manager to block all cookies from that site.

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M20

Updated

18 years ago
Summary: Right clicking in cookie manager should block site → [x]Right clicking in cookie manager should block site
Target Milestone: M20 → ---

Comment 1

18 years ago
It would be nice to have some sort of way to block the entire site from the
"Accept this cookie" prompt dialog.  I can't think of any way to do this that
wouldn't make the dialog too busy.

Updated

18 years ago
Summary: [x]Right clicking in cookie manager should block site → Right clicking in cookie manager should block site
Whiteboard: [x]

Updated

18 years ago
Whiteboard: [x] → [z]
Target Milestone: --- → Future

Comment 2

18 years ago
.
Assignee: morse → nobody
Status: ASSIGNED → NEW
Whiteboard: [z]

Comment 3

17 years ago
I truly wish that I could right-click and block the cookie(s) from an entire
domain.  (This is what I believe the reporter was referring to.

My 'reject' list has several .hitbox.com listings, for example.  It would be
nice to block *.hitbox.com, rather than the specific DNS name 'ads1.hitbox.com',
'ads2.hitbox.com', etc. etc.

For the 'accept this cookie' dialog, have an option to either block all cookies
from that site, or to block all cookies from that domain.  (Perhaps a click &
hold drop-down similar to the forward/backward buttons?)

And, the same idea holds for image blocking as well.

Comment 4

16 years ago
Whole domain blocking should be fixed by bug 78104 which curretly has a patch.
I do not know what the UI for this will be.  Currently you have to edit your
cookieperm.txt file.

Comment 5

16 years ago
*** Bug 168589 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

16 years ago
Troy is correct in comment 3, that is what is intended for this enhancement.

Since I reported the bug, I'm going to change the title to "Provide UI for
regexp cookie blocking", and make this bug dependant on bug 78104.
Depends on: 78104
Summary: Right clicking in cookie manager should block site → Provide UI for regexp cookie blocking

Comment 7

16 years ago
Is there a bug assigned to provide UI/ guidelines for regexp content blocking as
well?

Comment 8

16 years ago
Someone seems to have hijacked the image blocking bugs and shelved them all so
if you want this (privacy related issue) to be addressed you might want to
remove its dependency on <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=78104">bug 78104</a>.

Updated

15 years ago
Keywords: helpwanted
Priority: P3 → --
QA Contact: tever → cookieqa

Comment 9

15 years ago
-> defaults, removed from 78104

The original request was to be able to block a site and/or related domains when
looking at a stored cookie.

Regex implies a much higher level of complexity, bug 78104 is much different in
that regard. It is also related to image blocking, which should be treated as
completely separate now.
No longer depends on: 78104
Keywords: helpwanted
Summary: Provide UI for regexp cookie blocking → Cookie Manager: block sites from Stored Cookie tab
You can add arbitrary sites from the Cookie Sites tab, or delete the cookie 
with the "block sites that set deleted cookies" option checked.  There's no 
need to add yet another UI element to cookie manager to enable 
existing/superior functionality that already exists in another form.  The one 
potentially good option is to allow blocking the parent (i.e. 
*.doubleclick.net) but since that would really require the UI element plus a 
dialog, I don't think that's going to be a usability win over simply 
adding "doubleclick.net" to the blocked sites list.

There still remains the issue of "do we kill cookies for sites when blocking 
said sites"
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 11

15 years ago
V/wontfix.
Sounds fine to me.
Status: RESOLVED → VERIFIED
QA Contact: core.networking.cookies → benc
You need to log in before you can comment on or make changes to this bug.