Save session dialog missing at shutdown command, no session restore

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
major
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Chris Mack, Unassigned)

Tracking

3.5 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [closeme 2010-05-05])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel DC Mac OS X 10.5.8; de; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

3 to 5 windows and up to 15 tabs open in Firefox 3.5.3 
At shutdown shortcut no session save dialog (never watched this in FF 3.5.2)
Also no notification at startup.
Somtimes (Plugin.Installation, e.g.) sudden shutdown, but here FF 3.5.3 will show  an apology and sometimes successfully try to restore the tabs and windows.   

Reproducible: Sometimes
(Reporter)

Updated

9 years ago
Severity: normal → major
Keywords: common-issue+
Version: unspecified → 3.5 Branch
(In reply to comment #0)
> 3 to 5 windows and up to 15 tabs open in Firefox 3.5.3 
> At shutdown shortcut no session save dialog (never watched this in FF 3.5.2)
> Also no notification at startup.

Do you have your browser set to show windows & tabs from last time? This would suppress the dialog.

> Somtimes (Plugin.Installation, e.g.) sudden shutdown, but here FF 3.5.3 will
> show  an apology and sometimes successfully try to restore the tabs and
> windows.   

With default settings, this would happen after a 2nd crash. Do you know if Firefox has been crashing for you? You can check for recent crashes by typing "about:crashes" in your location bar.

> Reproducible: Sometimes

Since this is only sometimes reproducible, I'm led to believe you're crashing. If you can come up with steps to consistently reproduce, that would be very helpful.

Comment 2

9 years ago
Please don't use the common-issue+ keywords unless you're on the support team.
Keywords: common-issue+
(Email reply from Chris. Posting here for permanence)

> Do you have your browser set to show windows & tabs from last time? This would
> suppress the dialog.

But wouldn't that mean, that winsdows & tabs were restored at each startup anyway? - Because I get only that single window with the preset startup link.
However - with your hint I found another option unchecked: "Alert, if a multi tab window will be closed"
Even that makes me wonder, why a small update would not leave the settings untouched.

> > Somtimes (Plugin.Installation, e.g.) sudden shutdown, but here FF 3.5.3 will
> > show an apology and sometimes successfully try to restore the tabs and
> > windows.
>
> With default settings, this would happen after a 2nd crash. Do you know if
> Firefox has been crashing for you? You can check for recent crashes by typing
> "about:crashes" in your location bar.

about:crashes doesn't show me any rcent crashes for 3.5.1 ... 3..5.3

Comment 4

8 years ago
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.4) Gecko/20100413 Firefox/3.6.4
Please update if you are able to still reproduce with the latest nightly build  ftp://ftp.mozilla.org/pub/firefox/nightly/latest-trunk/
Whiteboard: [closeme 2010-05-05]
Resolving WORKSFORME since I cannot reproduce and the lack of requested feedback.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.