when connection breaks during addon install firefox breaks

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: Michal 'hramrach' Suchanek, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Firefox often gets into a state when addons waiting for installation are left in waiting state indefinitely and search does not work.

The cause seems to be a silent failure of addon download.

Sometimes firefox would report the download failed but sometimes it will quetly drop the addon after it has been downloading it for some time already, probably due to broken connection.

Reproducible: Sometimes
(Reporter)

Updated

8 years ago
Version: unspecified → 3.5 Branch
Component: General → Add-ons Manager
Product: Firefox → Toolkit
QA Contact: general → add-ons.manager
Version: 3.5 Branch → unspecified

Comment 1

7 years ago
Michal, do you see this in version 3.6 or 4.0 beta?
Whiteboard: [closeme 2011-01-20]
(Reporter)

Comment 2

7 years ago
This seems no longer an issue in 3.6
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
FIXED means "This bug was fixed on such-and-such a date by such-and-such a patch". If we don't know what made the bug disappear, we use WORKSFORME.
Resolution: FIXED → WORKSFORME
Whiteboard: [closeme 2011-01-20]
You need to log in before you can comment on or make changes to this bug.