Closed Bug 521700 Opened 11 years ago Closed 8 years ago

Download manager treats everything as "file links"

Categories

(SeaMonkey :: Download & File Handling, defect)

x86
Linux
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: aditsu, Unassigned)

Details

(Whiteboard: [Halloween2011Bug])

User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.4) Gecko/20091007 SeaMonkey/2.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.4) Gecko/20091007 SeaMonkey/2.0

Whenever I try to open a file from the download manager, it treats it as a file link and takes the action associated with the "file" content type, ignoring both the file type and the content type originally given by the server (if any).
For example, I associated konqueror with file links (for the purpose of opening directory paths) and now it tries to open everything from the download manager in konqueror.

Reproducible: Always

Steps to Reproduce:
1. Download any file (e.g. pdf, doc, xls, whatever) and save it
2. Go to the download manager and double-click it (or right-click and click Open)

Actual Results:  
It takes the action associated with file links

Expected Results:  
It should take the action associated with the file type
Version: unspecified → Trunk
The same thing happens in the download progress dialog, when using the (currently extremely-hidden super-secret) "open" action.
Note: in Linux you can use xdg-open to open a file with the default associated application. Still, even if it doesn't use that, SM should use its own associated application for the file type.
What Linux distro are you using?
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM]
Uh, you're only about 2 years late.
Lots of things changed since then, and this bug doesn't happen anymore for me in seamonkey 2.3.1
There's still one remaining issue: when I try to open the containing folder, it opens it in gwenview for some reason, and I can't find where to change that.
And what's up with this "halloween bug" stuff?!
Oh, and I'm using Gentoo Linux
(In reply to Adrian Sandor from comment #3)
> There's still one remaining issue: when I try to open the containing folder,
> it opens it in gwenview for some reason, and I can't find where to change
> that.

It should be using the standard viewer for folders set in GNOME settings.
I'm not using gnome
(In reply to Adrian Sandor from comment #6)
> I'm not using gnome

That doesn't matter, SeaMonkey is still querying it as it's using gtk/gnome backends.
Alright, then where can I configure that?
(In reply to Adrian Sandor from comment #8)
> Alright, then where can I configure that?

I don't know where GNOME keeps those, sorry.
Closing as WFM based on Comment 3
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
(In reply to Adrian Sandor from comment #3)
[...]
> There's still one remaining issue: when I try to open the containing folder,
> it opens it in gwenview for some reason, and I can't find where to change
> that.

SeaMonkey can use either your Gnome file chooser (by default) or its own file chooser (if ui.allow_platform_file_picker is set to false in about:config). To set where the containing folder is opened, try clicking the "Gnome Applications" button (with a big footprint icon) on your Gnome panel (usually at the bottom of your desktop), then "Personal Settings" and finally "File Associations".

> And what's up with this "halloween bug" stuff?!

That's so we can tally the bugs which were triaged during our SeaMonkey Halloween Bug Event and publish some stats. They are not yet ready as I'm writing this, but when they are, they will appear at https://wiki.mozilla.org/SeaMonkey/Bug_events/20111027#Results — once they are ready, it will be announced, among others, on the mozilla.dev.apps.seamonkey newsgroup on the news.mozilla.org news server.
Whiteboard: [Halloween2011Bug][CLOSEME 2012-01-01 WFM] → [Halloween2011Bug]
(In reply to Tony Mechelynck [:tonymec] from comment #11)
> try clicking
> the "Gnome Applications" button (with a big footprint icon) on your Gnome
> panel (usually at the bottom of your desktop)

Please refer to comment 6
(In reply to Tony Mechelynck [:tonymec] from comment #11)
> SeaMonkey can use either your Gnome file chooser (by default) or its own
> file chooser (if ui.allow_platform_file_picker is set to false in
> about:config).

This is something different. This is not the file picker, this is about the application used for opening a folder.

> To set where the containing folder is opened, try clicking
> the "Gnome Applications" button (with a big footprint icon) on your Gnome
> panel (usually at the bottom of your desktop), then "Personal Settings" and
> finally "File Associations".

He doesn't use GNOME, as discussed above.
You need to log in before you can comment on or make changes to this bug.