make cycle collector faults fatal

RESOLVED FIXED in mozilla14

Status

()

Core
XPCOM
RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: bsmedberg, Assigned: mccr8)

Tracking

Trunk
mozilla14
Points:
---

Firefox Tracking Flags

(blocking2.0 -)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

8 years ago
In bug 521750 we're going to make the cycle collector fault (instead of crashing) if external code uses it incorrectly off the main thread. This will fire a cycle-collector-fault observer notification. The user's browser is likely to leak like a sieve after the cycle collector faults, and they should restart at the first opportunity (and probably disable some extensions). This bug is about whatever UI Firefox needs to make this happen.
(Reporter)

Comment 1

8 years ago
Nominating for 3.6 but since we're past string freeze that doesn't seem likely.
blocking2.0: --- → ?
Flags: wanted-firefox3.6?
Flags: blocking-firefox3.6?
Yeah, past string freeze (wish someone brought it up last week when Axel was asking if there were any strings outstanding, or that I'd noticed it before then) so I don't think there's a lot we can do about this.

Adding user-doc-needed to get SUMO attention; post Firefox 3.6 we might see memory ramping due to lack of cycle collection. A better trade off than crashing, but we might want to add this to any "Firefox is using a lot of memory" documentation.

Benjamin: can you quantify "like a sieve"? Firefox 2 era memory leaks?
Flags: wanted-firefox3.6?
Flags: wanted-firefox3.6-
Flags: blocking-firefox3.6?
Flags: blocking-firefox3.6-
Keywords: user-doc-needed
(Reporter)

Comment 3

8 years ago
No, worse, as in "gmail or facebook will use all your memory in 5-10 minutes if not sooner".
(Reporter)

Updated

7 years ago
blocking2.0: ? → -
Given how reliant we are on the CC these days, I think we should just abort.  As a bonus, we'll be able to see when this happens in Socorro.

bsmedberg, do you have objections to changing the cc fault to NS_RUNTIMEABORT?
(Reporter)

Comment 5

5 years ago
No, I think you should go for it (on -central). Please ask crashkill to watch for upticks related to this.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 733460
(Assignee)

Comment 7

5 years ago
khuey, if you don't have time to do this in the next week or so let me know and I can do it.  Probably best to wait until Firefox 14 at this point.
Assignee: nobody → khuey
(Assignee)

Updated

5 years ago
Keywords: user-doc-needed
OS: Windows NT → All
Hardware: x86 → All
Version: unspecified → Trunk
(Assignee)

Comment 8

5 years ago
Created attachment 605136 [details] [diff] [review]
make cycle collector faults fatal, plus a little cleanup of faults
Assignee: khuey → continuation
(Assignee)

Comment 9

5 years ago
Created attachment 606250 [details] [diff] [review]
make cycle collector faults fatal

I did a try run on Linux for an earlier version that was fine.  I'll do a full try run before I land it.
Attachment #605136 - Attachment is obsolete: true
Attachment #606250 - Flags: review?(bugs)

Updated

5 years ago
Component: General → XPCOM
Flags: wanted-firefox3.6-
Flags: blocking-firefox3.6-
Product: Firefox → Core
QA Contact: general → xpcom
Summary: Firefox should display something/inform the user if the cycle collector faults → make cycle collector faults fatal
(Assignee)

Comment 10

5 years ago
Comment on attachment 606250 [details] [diff] [review]
make cycle collector faults fatal

Does this sound reasonable to you, Peter?
Attachment #606250 - Flags: feedback?(peterv)

Updated

5 years ago
Attachment #606250 - Flags: review?(bugs) → review+
(Assignee)

Comment 11

5 years ago
Created attachment 606279 [details] [diff] [review]
make cycle collector faults fatal

Gavin pointed out that I flipped the cases in the if.  I managed to mangle the code when I was undoing some changes I made before. Carrying forward smaug's review.
Attachment #606250 - Attachment is obsolete: true
Attachment #606279 - Flags: review+
Attachment #606279 - Flags: feedback?(peterv)
Attachment #606250 - Flags: feedback?(peterv)
(Assignee)

Comment 12

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/11660ce3640a
Target Milestone: --- → mozilla14
(Assignee)

Updated

5 years ago
Attachment #606279 - Flags: feedback?(peterv)
https://hg.mozilla.org/mozilla-central/rev/11660ce3640a
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.