All non-North American traffic to store.mozilla.org should redirect to International Store

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: David Boswell, Assigned: justdave)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
Can we set up a redirect on store.mozilla.org to send all non-US and Canadian traffic to the International Store?

http://intlstore.mozilla.org/

This type of redirect had been in place when the store was up previously, but we should add that back since international users are unaffected by the domestic store issue.

Comment 1

9 years ago
Just wanted to second this request...anything you guys could do would be a big help. Our International Store is currently losing a lot of traffic b/c of the lack of a redirect.

Thanks!
Assignee: jslater → server-ops
Component: store.mozilla.org → Server Operations
Product: Websites → mozilla.org
QA Contact: store-mozilla-org → mrz
Version: unspecified → other
(Reporter)

Comment 2

9 years ago
To add a note about timing, our relationship with the International Store vendor is dependent on getting traffic back to their site.  Ideally we could get this fixed by end of this week.  If that's not realistic, please let me know an estimate so we can plan on our end.
Severity: normal → major
As a short-term fix while we figure out the GeoDNS stuff, it should be really easy to add a link to the international store on the downtime page.

"Customers outside the US and Canada: The international store is still open! <a>Go there!</a>" or somesuch.
Feel free to make suggestions if there's better text to use.
(Reporter)

Comment 6

9 years ago
justdave, that note on the page is great.  That should at least fix part of the problem for now.
Reload and let me know what you think.  I just re-did the page with the new mozilla.org design.

Comment 8

9 years ago
Looks great to me - Dave, thanks for all your help with this...this page is looking WAY better.

Do you have an estimate of when the GeoDNS stuff will be in place?
(Reporter)

Comment 9

9 years ago
This looks great to me too.  Thanks for the quick store redesign :)
The GeoDNS stuff that we have easily at our disposal at the moment works at the DNS level - that is, it returns a different IP address for the domain depending on where you make the DNS lookup from.  The problem with this is if we just put in the intlstore's IP address for the non-north-american response, then we'd get requests for store.mozilla.org going to the international store, which their server might not be prepared to handle.  So in order to make it work right, we need to set up a separate vIP here for store.mozilla.org, one serving the downtime page, and the other serving a 302 redirect to the international store. I'm not quite sure how to do that, so I'm not sure how long it'll take...  this is still in the server-ops queue in case someone else knows how, and I'll poke around on IRC in the meantime.
(Reporter)

Comment 11

9 years ago
If it would be useful, I imagine John or I could set up a call with the IT team at Gateway.
It wouldn't... merchandisemania is the party involved here.
part of the problem is the two people who would know how to set this up are both offsite today.  This can definitely all be handled on our end, it just might be tomorrow before it happens.
Assignee: server-ops → justdave

Comment 14

9 years ago
(In reply to comment #13)
> part of the problem is the two people who would know how to set this up are
> both offsite today.  This can definitely all be handled on our end, it just
> might be tomorrow before it happens.

That schedule sounds fine, thanks Dave. If you still want us to set up a call with merchmania, let me or David know...I'm sure they'd be glad to talk about this.
OK, I got the redirect IP set up on the Netscaler...  went to put it into the geodns server, and discovered it only seems to know about "China" and "other" and doesn't seem to have an option for "North America" and "other" which is what I need.  There's two geodns servers though, and I don't know how the second one works.

Here's what I attempted to do: (global means that's the fallback when nothing else matches)

103) UK GLOBAL store-moz-org.geo.mozilla.com         A 63.245.209.118  3600
102) US        store-moz-org.geo.mozilla.com         A 63.245.209.11   3600

Anyone know how to set this up right in zxtm? :)
OK, the zxtm-based GLB only does the distance-probing (route you to the closest colo) not country-based routing.  So the first server I was messing with already is the one it'll need to be done on.  Unfortunately, the change I need to make to it to make it do this is fairly invasive and stands a chance of screwing up the DNS for www.mozilla.org if I do it wrong, so I would recommend holding off for an outage window (probably Tuesday?) to make this change.  Hopefully having the prominent link to the international store on the downtime page will be enough in the meantime.

Comment 17

9 years ago
Tuesday sounds great - thanks Dave!
The DNS way is going to be way complex/hackish.  I used the example from http://knowledgehub.zeus.com/articles/2007/09/18/geolocation and added a Request rule called "store-geo-redirect".

justdave/oremj - let's move store.mozilla.org over to ZXTM and use this rule. 

If you have access to a IP known to be registered outside of CA/US (sg-zlb01.mozilla.net, for instance), you can test with:

curl -v  http://63.245.213.95/

US/CA sites throw you to the error page.  Elsewhere you get a 301.
I just flipped DNS for store.mozilla.org to 63.245.209.8, behind ACE/ZXTM with a version of the geolocation code in place.  

Any matches to US or CA traffic fall through to store.mozilla.org.  Anything else gets a 302 to https://intlstore.mozilla.org/.  

Tested from local folk in Singapore.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Summary: All non-US and Canadian traffic to store.mozilla.org should redirect to International Store → All non-(US and Canadian) traffic to store.mozilla.org should redirect to International Store

Updated

9 years ago
Summary: All non-(US and Canadian) traffic to store.mozilla.org should redirect to International Store → All non-North American traffic to store.mozilla.org should redirect to International Store
And testing from Japan as well, it redirects.

Tested from Canada, it doesn't.

Which also begs some clarification.  Canada is supposed to get the US store, right?  When I hit intlstore.mozilla.org from a US IP, I get a note in the lower left corner saying I'm accessing from the US, and click to visit the US store.  When I hit intlstore.mozilla.org from a Canadian IP, I get no such note.
(Reporter)

Comment 21

9 years ago
I'll confirm with Merchandise Mania about the question in comment #20.
(Reporter)

Comment 22

9 years ago
Merchandise Mania confirmed that Canadian users should be directed to the US store.
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.