Delete Button of the Toolbar is not working for Cancel posted news messages

VERIFIED DUPLICATE of bug 39692

Status

MailNews Core
Networking: NNTP
P3
normal
VERIFIED DUPLICATE of bug 39692
18 years ago
10 years ago

People

(Reporter: Karen Huang, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Delete Button of the Toolbar is not working for Cancel posted news messages

Used 09-11-08-M18 commercial build

1) After subscribe news/newsgroups messages
2) Posted newsgroup messages
3) Select the posted newsgroups messages from the thread pane
4) Select the "Delete" button from the Toolbar

Actual Result: Nothing happened
Expected results: Should Prompt confirm dialog for canceling newsgroups messages
(Reporter)

Updated

18 years ago
Keywords: nsbeta3
the delete button doesn't work on purpose.

in 4.x, when reading news we hid the delete button.
in 6.0, we should either hide it or disable it, since it does nothing.

cc'ing jennifer glick for comment.

Comment 2

18 years ago
In 4.x when a newsgroup is selected, the "Delete" button is removed and "Mark" 
appears on the Toolbar.

I would recommend removing the "Delete" button when a newsgroup has focus.

(In 4.x, if the user is the author of the selected news posting, they can cancel 
the posting using the Edit menu.  I think this got cut for Seamonkey though?)
in 6.0, you can cancel from the edit menu.
but instead if saying "cancel message" it says "delete message".

I think there is a bug on this already.

I don't think this bug meets our nsbeta3 bug requirements.  it's a UI polish
issue.  clearing keyword.
Keywords: nsbeta3

Comment 4

18 years ago
Dup of 39692 a bug to remove the Delete button when in News.

*** This bug has been marked as a duplicate of 39692 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
QA Contact: esther → nbaca
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

18 years ago
Verified as dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.