N tabs + proxy identification generate N windows for proxy authentication

RESOLVED DUPLICATE of bug 356097

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 356097
9 years ago
9 years ago

People

(Reporter: ddv36a78, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

I have often N tabs running inside Firefox. And, when I re-open Firefox, it opens again these N tabs. Just cool.

But my enterprise network requires proxy authentication. And then, the dream goes crazy.

Indeed, Firefox asked me proxy authentication for each tab. So, Firefox just opens at least 1 proxy authentication window for each existing tab.
Then, Firefox opens N proxy authentication windows and it has drawbacks :
- first, N windows are opened and N could be great,
- secondly, I have not enough time to fill any single authentication window because I lost rapidly the focus while Firefox is opening the next window. 
So, I click on the "Cancel" button to cancel all M windows (with M >> N because Firefox opens new windows when opening new connections again and again).

At the end, when Firefox stays a little calm, I open some page, like a Google page, in order to let Firefox asks only once the authentication parameters.
And then, while thoses parameters are recorded by Firefox, I can reloaded all other pages while Firefox use the recorded information and does not ask those items again.

Reproducible: Always



Expected Results:  
The first time Firefox detects a need for proxy authentication, it should open a window in order to let users entering authentication information. OK.

But, the next time proxy authentication is needed, if there is already an opended authentication window for the same proxy, Firefox should be able to recognize it's the same proxy in order not to open a new authentication window, but to factorize uses of authentication window to use results for multiple (client) tabs.

One problem is that some users may have multiple accounts for a single proxy. So, I see 2 solutions:

SOLUTION_1 : define a Firefox property in order to authorize Firefox to reuse the same authentication information for the same proxy. Then, if this option is choosen, Firefox is able to do what I have described above, that is, to factorize all authentication windows into a single one is the targeted proxy is detected to be the same.

SOLUTION_2: Authorize only one authentication proxy window to be open at any time. Then, users would be able to enter authentication information without losing the focus (just like when multiple such windows are open very quickly), and then, the user experience will be less crazy.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 356097

Comment 2

9 years ago
This bug is not fixed , i am using version 3.5.5
You need to log in before you can comment on or make changes to this bug.