Unresponsive script dialog deadlocks print dialog (save as pdf)

RESOLVED DUPLICATE of bug 476541

Status

()

Firefox
Shell Integration
--
critical
RESOLVED DUPLICATE of bug 476541
9 years ago
9 years ago

People

(Reporter: Elias Hedberg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_8; sv-se) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

I had opened the print dialog and its sub-dialog "Save as PDF…", when the "Unresponsive script" dialoge showed up in the same window (behind the print dialogs). The print dialogs prevented the "Unresponsive script" dialog from responding to my actions (neither "Continue" nor "Stop execution"(?) worked), and the "Unresponsive script" dialog prevented the "Save as PDF" dialog from responding to my actions (neither "Save" nor "Cancel" worked); the "Save as PDF…" dialog, in its turn, always prevents the main print dialog from responding, but that’s normal and expected behaviour.

Reproducible: Didn't try

Steps to Reproduce:
1. Go to any page.
2. Open the print dialog.
    (Mine was opened by pressing "Print" on Ryanair’s confirmation page after buying a ticket, but probably any way of opening it will do, such as pressing cmd+p or choosing "Print…" from the File menu.)
3. Choose "Save as PDF…".
4. There must now be a script on the page that causes Firefox to show the "Unresponsive script" dialog. 
    (I don’t know if you can force it to do that somehow. The script that caused it for me was one belonging to the plugin "AutoPager": "chrome://autopager/content/autopager.js:3688".)
5a. Click "Save" in the "Save as PDF…" dialog.
5b. Click "Cancel" in the "Save as PDF…" dialog.
5c. Click "New folder" in the "Save as PDF…" dialog.
5d. Click "Continue" in the "Unresponsive script" dialog.
5e. Click "Stop script" in the "Unresponsive script" dialog.
Actual Results:  
5a. The "Save" button looks as if it were clicked, but nothing happens (the dialogs are still there and there is no new PDF document where I chose to save it).

5b. The "Cancel" button looks as if it were clicked, but nothing happens (the dialogs are still there).

5c. A new folder is created in the active/chosen folder. (So, creating new folders still works in the "Save as PDF…" dialog.)

5d. The "Continue" button looks as if it were clicked, but the "Unresponsive script" dialog is still there. The script continues to execute.

5e. The "Stop script" button looks as if it were clicked, but the "Unresponsive script" dialog is still there and the script continues to execute.

Expected Results:  
5a. The "Save as PDF…" dialog and the print dialog should close and the document should appear where you chose to save it.

5b. The "Save as PDF…" dialog and the print dialog should just close.

5c. A new folder should be created in the active/chosen folder.

5d. The script should continue to execute and the "Unresponsive script" dialog should close.

5e. The script should stop executing and the "Unresponsive script" dialog should close.

This bug can indirectly cause information loss:

In my case I could not print the confirmation of my purchase (of a flight ticket, with reservation number etc.), luckily the actual confirmation number happened to be visible, so I could always have copied it by hand, I am not sure if I could have scrolled up/down to see it if it had not been visible (I didn’t think about trying that before force-quitting Firefox.). Also: Ryanair, and many other sites selling things on the Internet,  also sends a confirmation e-mail with all the important information, so the data wasn’t seriously threatened in this case.

However, depending on the routines of the site, you might in unlucky cases loose critical data (though many pages will not have critical data in the first place, and reloading them after restarting Firefox will show them in the state you left them, but pages showing receipts and confirmations might not show up as you left them).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476541
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> 
> *** This bug has been marked as a duplicate of bug 476541 ***

Thanks Matthias. I thought I had covered the potential duplicates in my pre-filing search.
You need to log in before you can comment on or make changes to this bug.