Database needs to be written to using UTF-8 not binary

RESOLVED DUPLICATE of bug 503523

Status

addons.mozilla.org Graveyard
Public Pages
P1
normal
RESOLVED DUPLICATE of bug 503523
8 years ago
2 years ago

People

(Reporter: davedash, Assigned: davedash)

Tracking

Details

(URL)

Currently all the data in the db is not UTF-8, we need to fix this.:

1. for all cake connections do "mysql_set_charset('utf8');
2. do a data correction for the translations table.

This breaks sphinx, and anything else that requires the data to be utf-8.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503523
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.