Closed Bug 522286 Opened 11 years ago Closed 11 years ago

Firefox crashes after redirect to iDeal (Dutch online payment) website [@SinkContext::DidAddContent(nsIContent*) ]

Categories

(Firefox :: General, defect, critical)

x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jesse.houwing, Unassigned)

References

()

Details

(Keywords: crash)

Crash Data

Firefox crashed 4 times in a row while trying to redirect me to the iDeal website, the problem is, this happened while ordering mexican food at the dutch TacoMundo website, so I cannot give you a precise set of steps to reproduce.

Entering the redirect URL manually does not crash firefox, so it's probably something in the redirect itself.

Crash ID: bp-2b2957e3-6550-4237-a5cf-783d52091014
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091013 Minefield/3.7a1pre (.NET CLR 3.5.30729)

Running 32 bits version on Windows 7 x64 Ultimate
Summary: Firefox crashes after redirect to iDeal (ducth online payment) website → Firefox crashes after redirect to iDeal (Dutch online payment) website
For anyone who wants to try:

Steps to reproduce:
- Open tacomundo.nl
- click "online bestellen"
- enter a valid dutch postalcode (e.g. 3581LK)
- order some items
- click "bestellen"
- Enter address details (Woonplaats = "Utrecht")
- Select iDeal as betalingsmethode (payment method)
- Select ABN AMRO as bank
- click "Plaats Bestelling!"

Expected results:
- I am redirected to the Dutch ABN AMRO iDeal payment website

Actual results:
- Firefox crashes

Installed add-ons:
- Adblock Plus
- .NET CLR 3.5 ClickOnce

Installed plugins:
- Java 1.6
- Flash
- Windows Media Player
I haven't noticed a crash yet with the ING bank.
Your crash ID doesn't contain much info, was it a nightly?
It could be Bug 519926 because it is in xul.dll and that is a popular crash, but that is only a wild guess. :)
Whiteboard: [needs crashreportid]
Yup it's from a nightly build
Gecko/20091013 Minefield/3.7a1pre
Crash ID: bp-350a552a-8ac5-4888-9d23-6b34b2091014:

0  	xul.dll  	SinkContext::DidAddContent  	 content/html/document/src/nsHTMLContentSink.cpp:729
1 	xul.dll 	SinkContext::AddLeaf 	content/html/document/src/nsHTMLContentSink.cpp:1156
2 	xul.dll 	HTMLContentSink::ProcessLINKTag 	content/html/document/src/nsHTMLContentSink.cpp:2812
3 	xul.dll 	HTMLContentSink::AddLeaf 	content/html/document/src/nsHTMLContentSink.cpp:2289
4 	xul.dll 	CNavDTD::AddHeadContent 	parser/htmlparser/src/CNavDTD.cpp:2986
5 	xul.dll 	CNavDTD::HandleStartToken 	parser/htmlparser/src/CNavDTD.cpp:1374
6 	xul.dll 	CNavDTD::HandleToken 	parser/htmlparser/src/CNavDTD.cpp:714
7 	xul.dll 	CNavDTD::BuildModel 	parser/htmlparser/src/CNavDTD.cpp:301
8 	xul.dll 	nsParser::BuildModel 	parser/htmlparser/src/nsParser.cpp:2422
9 	xul.dll 	nsParser::ResumeParse 	parser/htmlparser/src/nsParser.cpp:2320
10 	xul.dll 	nsParser::ContinueInterruptedParsing 	parser/htmlparser/src/nsParser.cpp:1823
11 	xul.dll 	nsContentSink::ContinueInterruptedParsingIfEnabled 	content/base/src/nsContentSink.cpp:1756
12 	xul.dll 	nsRunnableMethod<nsGlobalWindow,unsigned int>::Run 	obj-firefox/dist/include/nsThreadUtils.h:264
13 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527
14 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:170
15 	xul.dll 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:182
16 	nspr4.dll 	PR_GetEnv 	
17 	firefox.exe 	wmain 	toolkit/xre/nsWindowsWMain.cpp:110
18 	firefox.exe 	__tmainCRTStartup 	obj-firefox/memory/jemalloc/crtsrc/crtexe.c:591
19 	kernel32.dll 	kernel32.dll@0x13676 	
20 	ntdll.dll 	ntdll.dll@0x39d71 	
21 	ntdll.dll 	ntdll.dll@0x39d44
Summary: Firefox crashes after redirect to iDeal (Dutch online payment) website → Firefox crashes after redirect to iDeal (Dutch online payment) website [@SinkContext::DidAddContent(nsIContent*) ]
Whiteboard: [needs crashreportid]
Jesse, the ordering is only possible between 4p and 10pm MEZ, is that correct?
CET, but yes. Very annoying :)
i failed to reproduce with 3.5.4, 3.6 beta 1 and a recent trunk nightly, on XP though.
you are being redirected to https://ideal.abnamro.nl/nl/ideal/identification.do?randomizedstring=<10 digits here>&trxid=<14 digits here>
Indeed WFM 
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20091104 Minefield/3.7a1pre (.NET CLR 3.5.30729
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@SinkContext::DidAddContent(nsIContent*) ]
You need to log in before you can comment on or make changes to this bug.