Fennec should handle MozApplicationManifest

VERIFIED FIXED in fennec1.0b5

Status

--
blocker
VERIFIED FIXED
9 years ago
5 years ago

People

(Reporter: vingtetun, Assigned: vingtetun)

Tracking

Trunk
fennec1.0b5
Bug Flags:
in-litmus +

Details

(URL)

Attachments

(1 attachment)

Created attachment 406245 [details] [diff] [review]
Patch

Actually Fennec don't listen the MozApplicationManifest event sent by the platform if a website declare a manifest to store offline data.

The patch turn it on. It is mostly a port of the way it is done in Firefox without the managing part of the size handle by the offline data since we don't have any UI to manage the offline data.
Flags: wanted-fennec1.0?
tracking-fennec: --- → ?
It also misses an icon (see XXX) in the patch, I'm not sure we need one for now though.
Comment on attachment 406245 [details] [diff] [review]
Patch

God for getting the basics to work.

* Let's remove the icon
* Let's remove the accessKeys

I can do that on checkin
Attachment #406245 - Flags: review+
removed icon and accesskeys. tweaked message text based on madhava irc input

pushed:
https://hg.mozilla.org/mobile-browser/rev/3d7c0dd9bcd1
Assignee: nobody → 21
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
This feature is up on builds:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091015
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091015
Fennec/1.0b5pre

but there's a follow up bug on issues with this implementation: bug 522493 , bug 522495 , bug 522496
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Litmus test case id #9787 was created to handle regression testing this bug.
Flags: in-litmus? → in-litmus+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.