Radio buttons no longer respond to hover:active CSS styles

RESOLVED FIXED

Status

()

Core
XUL
P3
normal
RESOLVED FIXED
18 years ago
18 years ago

People

(Reporter: Nikhil Bhatla (gone), Assigned: David Hyatt)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build # 2000091108 Windows
Self-Build this Morning of Mac

1) Start up the Browser (in either the Modern or Classic Skin).
2) Open the Preferences panel from the View menu.
3) Click and hold on a radio button in the Navigator Panel for "When Netscape
starts up, display..." group.

Expected Behavior: The radio button's image should change when you click and
hold with the mouse, visually indicating a press.

BUG: No new image is displayed.  This was working fine when I implemented the
classic skin on Mac about a month ago.  Anyone know what happened.  Checkboxes
still respong correctly.

Comment 1

18 years ago
broken in today's verification build also.  ->future.
Target Milestone: --- → Future

Comment 2

18 years ago
This is mac/win32/linux for both skins. 

Curiously, it only happens when the <radio> elements are contained inside 
a <radiogroup>. Put <radio> inside a plain <box> and it works correctly
(goes into the :active state). This worked in a Sep01 build, but not now.

There have been some changes related to focus in radioBindings.xml and 
radio.css in the past week, but not sure if those are related to this. 
CC: Ben to see if he has any clues for sale.
Hardware: Macintosh → All
Target Milestone: Future → ---

Comment 3

18 years ago
Why did you remove future? If it belongs to some other group, then please
reassign, but if it is ours, I think it should be futured because it does not
fit the profile. 

Comment 4

18 years ago
Oops. Sorry. I did not mean to do that (remove Future). 

However, I now see that this is Ben's bug, so reassigning to him.

Ben, I dropped the Sep01 versions of xul.css and radioBindings.xml into
a current build, and <radio> now will take on a :active style. Looks like
those changes are the culprit. 
Assignee: trudelle → ben
(Assignee)

Comment 5

18 years ago
mine
Assignee: ben → hyatt
(Assignee)

Comment 6

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.