"Components is not defined" in error console

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: davemgarrett, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
With 3.7a1pre and javascript.options.showInConsole=true
1) Minefield start page http://www.mozilla.org/projects/minefield/
2) Open DOM Inspector 2.0.3
3) Click the drop down arrow on the left side and select various items
4) Error Console gives a bunch of:

Error: Components is not defined
Source File: chrome://global/content/bindings/tree.xml
Line: 78
Which drop down arrow? The for the viewers menu, which the DOM, Style Sheets, etc. viewers?

I don't get any errors, but it sounds like there's something else at play here; Components should definitely be defined. If there is a problem, it's not going to be specific to the DOM inspector.
Er, that should say "The one for the viewers menue, which lists the DOM, Style Sheets, etc. viewers?".
(Reporter)

Comment 3

9 years ago
Sorry, I wasn't clear enough. Yes, the menu with DOM Nodes, Stylesheets, JavaScript Object, Accessible Events, & Accessible Tree.

Click through the different views in order a few times. My error console spams up rather quickly with them from that. Also getting a couple of the same error for button.xml mixed in.

I tried testing again with new profiles in latest Minefield on both Linux and Windows XP. It's not coming up every click, which is odd, but I can get it on both rather quickly and frequently. If it doesn't error when I click one, then I click another, it errors and may error again when I click back to the previous view.

Did you have javascript.options.showInConsole=true? If you didn't, set it in about:config and restart Firefox. It won't bother reporting the error without it.

Odd note: some of the errors don't show with the line number listed. Same error though.
> Error: Components is not defined
> Source File: chrome://global/content/bindings/tree.xml

Something bigger is happening. This should maybe be filed against Core/XPConnect.
I've seen this before in my extension too, Components just fails unreproducibly necessitating a browser restart.
I've filed bug #580570 on setTimeout failures, which seems to be the same issue as the failure to find global variables issue reported here.

Just curious, does DOM Inspector use JS Code Modules?  Just based on when this sort of thing started appearing for me, I suspect them to be the cause.
(Reporter)

Comment 8

7 years ago
I just tried to reproduce this with current DOM Inspector and current stable and nightly Firefox versions. Can't see any errors from my old STR anymore. -> WFM
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.