If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mysterious numbered folders created in Inbox, error when trying to delete

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Mike, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10_5_8; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Build Identifier: 3.0b4

Opened Thunderbird and see two identical numbered folders created in Inbox folder view.  I try to delete one folder and get error "Alert, A folder with that name already exists. Please enter a different name."

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. restart os x
2. open thunderbird



OS X 10.5.8, PowerMac G5 1.8 dp 4 GB ram

Comment 1

8 years ago
Do you mean two numbered folders underneath the smart inbox? a screen shot might help...
David, look at the url link it contains a screenshot !
(Reporter)

Comment 3

8 years ago
This is really odd, here is another screenshot with more folders being created (in green):
http://bowenimagery.com/images/tbird2.jpg

I know the colon : character can cause problems and is generally not allowed for folders on mac, you'll notice one of my folders is called 11:11.  I tried to rename the folder and it wouldn't let me, then i found myself in an alert loop and had to force quit.  I presume the issue is with that character but i can't delete it now..any idaes?

Comment 4

8 years ago
yes, this issue is because of illegal characters in the folder names. If a folder name contains illegal characters, we create the folder on disk with a hashed number, and store the original folder name in the .msf file. If the .msf file gets deleted, we lose track of the original folder name, and display the hashed number.

If you want to delete the folder, you can delete the hashed file and the .msf equivalent from your user profile directory. Or you can rename it there as well (deleting the .msf file, but renaming the file without an extension).

I'm not sure why you couldn't rename the folder in the UI - what error did it give you?
(Reporter)

Comment 5

8 years ago
I wish i knew more about what the "hashed file" and .msf is so i can delete this thing...can you give me newbie instructions where to go on a mac to delete this?

Here's the alert:
"The folder could not be renamed. Perhaps the folder is being reparsed, or the new name is not a valid folder name."

I hit OK and the Alert keeps coming back until i click on another folder...

Comment 6

8 years ago
Are you trying to rename the folder to an existing folder name? Or are you trying to delete it? You might try emptying the trash first, then try deleting the folder;

Your user profile directory is in the <username>/Library/Thunderbird/Profiles/xxxx.default/Mail/<server name> or Local Folders
(Reporter)

Comment 7

8 years ago
David, thank you that worked!

This may be obvious, but I would put requesting to put an alert in the UI "character not allowed in folder name"

I will wait a day or so before i mark this as resolved to see if i see any other magic folders
(In reply to comment #7)
> David, thank you that worked!
> 
> This may be obvious, but I would put requesting to put an alert in the UI
> "character not allowed in folder name"
> 
> I will wait a day or so before i mark this as resolved to see if i see any
> other magic folders

So mike how does it look ?
(Reporter)

Comment 9

8 years ago
The 11:11 folder mysteriously came back today!!  

now what?
(Reporter)

Comment 10

8 years ago
now I have two folders...emptied trash again...
Maybe you should change the folder names to make the issue disapear (I mean on your server).
(Reporter)

Comment 12

8 years ago
i went back to <username>/Library/Thunderbird/Profiles/xxxx.default/Mail/<server name> and deleted everything, started over and it seems to be fixed at this point.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.