Cannot delete a file after uploading it

RESOLVED DUPLICATE of bug 183689

Status

()

RESOLVED DUPLICATE of bug 183689
9 years ago
9 years ago

People

(Reporter: jsp, Unassigned)

Tracking

3.5 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

2 bytes, application/octet-stream
Details
(Reporter)

Description

9 years ago
Steps:

1) Visit a page with a file upload control on it, such as http://validator.w3.org/#validate-by-upload.
2) Select a file to upload and upload it.
3) Find the original file and attempt to delete it.

Rather than deleting the file, Windows displays a message box with the caption "Error Deleting File or Folder" and the text "Cannot delete <the_file_name_here>: It is being used by another person or program.  Close any programs that might be using the file and try again."  The file can be deleted only after Firefox is shut down.

Uploading an additional file doesn't release the first one; you end up with two files that cannot be deleted.

This is not a new bug.  It has been annoying me on various machines for years, and I've finally decided it is worth the effort of reporting it.

It doesn't seem to affect the Mac; I can move an uploaded file to the trash without incident.
(Reporter)

Comment 1

9 years ago
Created attachment 406444 [details]
Test upload

I'm uploading an empty file to see whether this bug can be reproduced using bugzilla.
(Reporter)

Comment 2

9 years ago
The bug doesn't manifest if you upload an attachment to bugzilla.  How odd.  I've seen it with a number of other sites.
(Reporter)

Comment 3

9 years ago
I wonder if the doctype has anything to do with it.  The validator page uses "-//W3C//DTD XHTML 1.0 Strict//EN", while bugzilla uses "-//W3C//DTD HTML 4.01 Transitional//EN".  I'm grasping at straws; I don't see any obvious differences in what the two pages are doing.

Comment 4

9 years ago
See the comments in bug 183689 - it's often caused by the LiveHTTPHeaders or Firebug extensions.

see also bug 459384
(Reporter)

Comment 5

9 years ago
Darn.  I didn't think to search for "lock."  At least I'm not the first.

Disabling LiveHTTPHeaders does indeed fix the problem.  At least in my case, Firebug doesn't seem to trigger it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Resolution: FIXED → DUPLICATE
Duplicate of bug: 183689
You need to log in before you can comment on or make changes to this bug.