firefox exits silently if ~/.mozilla not accessible

RESOLVED DUPLICATE of bug 448845

Status

()

RESOLVED DUPLICATE of bug 448845
9 years ago
9 years ago

People

(Reporter: mcepl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090911 Fedora/3.5.3-1.fc12 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090911 Fedora/3.5.3-1.fc12 Firefox/3.5.3

Firefox silently fails to start if ~/.mozilla is owned by another user and can not be accessed.

Reproducible: Always

Steps to Reproduce:
1. chown root.root ~/.mozilla
2. chmod 700 ~/.mozilla
3. firefox
Actual Results:  
Silent failure.

Expected Results:  
An error or warning message would note the lack of access to ~/.mozilla.

If possible, Firefox should execute without access to ~/.mozilla without features like on-disk caching after displaying a warning message. If not, an error should explain why Firefox exited.
(Reporter)

Comment 1

9 years ago
(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=164621)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 448845
You need to log in before you can comment on or make changes to this bug.