Closed Bug 522486 Opened 11 years ago Closed 11 years ago

Password notification bar extends past screen view

Categories

(Firefox for Android Graveyard :: General, defect)

Fennec 1.1
defect
Not set
blocker

Tracking

(Not tracked)

VERIFIED FIXED
fennec1.0b5

People

(Reporter: aakashd, Assigned: vingtetun)

References

Details

(Keywords: qablocker)

Attachments

(1 file)

Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091015
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091015
Fennec/1.0b5pre

Steps to Reproduce:
1. Go to bugzilla.mozilla.org
2. Log out of bugzilla if you're loggedin
3. Go to the log-in screen and try to log in.

Actual Results:
The notification bar extends past the right side of the screen view on the n810 and n900. I have not verified this on WinMo builds.
tracking-fennec: --- → ?
Gah, this is a regression since (at least) 10/12

seen on build:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2b1pre) Gecko/20091012 Fennec/1.0a4pre
Severity: major → blocker
Ugh, this seems to be related to the width of the web content and/or the zoom level. If the page is zoomed and requires panning left/right to see the full width, then the notification box extends the width of the content.
Duplicate of this bug: 523723
Keywords: qablocker
Attached patch PatchSplinter Review
Assignee: nobody → 21
Attachment #408772 - Flags: review?(mark.finkle)
Comment on attachment 408772 [details] [diff] [review]
Patch

seems to work well
Attachment #408772 - Flags: review?(mark.finkle) → review+
pushed:
https://hg.mozilla.org/mobile-browser/rev/96805be1bafe
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
verified FIXED on builds:

Mozilla/5.0 (X11; U; Linux armv7l; Nokia N900; en-US; rv:1.9.2b2pre) Gecko/20091028 Namoroka/3.6b2pre Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; Nokia N8xx; en-US; rv:1.9.3a1pre) Gecko/20091028 Namoroka/3.7a1pre Fennec/1.0b5pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.