If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmarks Sidebar: Clicking the bottom displayed bookmark, when it's partially clipped, opens the bookmark below the clicked one

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: David K, Unassigned)

Tracking

unspecified
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(status1.9.1 wontfix)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

When more bookmarks exist in the Bookmarks Sidebar than can be displayed in one screenful, if the bottom displayed bookmark is clipped off, then left-clicking this clipped bookmark causes the Sidebar contents to scroll downward one item (to fully display the clicked item, as expected), but then Firefox selects the bookmark *below* the clicked bookmark, and brings up that webpage instead.

Reproducible: Always

Steps to Reproduce:
1. Display the Bookmarks Sidebar.
2. Be sure there are more bookmarks stored than will fit on one screenful.  (Add more bookmarks if necessary so that some bookmarks exist below the last-displayed bookmark in the Bookmarks Sidebar.)
3. Resize the Firefox window, if necessary, so that the bottom displayed bookmark in the Bookmarks Sidebar is clipped (that is, its text is only partially displayed.)  There must be more bookmarks in the sidebar below this clipped bookmark, in order to reproduce this bug.
4.  Click the partially-displayed bookmark at the bottom of the Bookmarks Sidebar.
Actual Results:  
The Sidebar scrolls down a little to fully display the clicked bookmark (this is a good thing), but then the item below the clicked item is magically selected, and Firefox browses to that bookmark instead of the clicked one.



Expected Results:  
The Sidebar scrolls down a little to fully display the clicked bookmark, and Firefox browses to the bookmark that was clicked.

This can cause Browse Confusion for the unsuspecting user, because if you don't notice what happened in the Sidebar, you'll wonder why the wrong page is being brought up by Firefox.

I notice this problem almost every day, because just by chance one of my favorite bookmarks (no, it's not a porn site!) occurs right at the bottom of my Bookmarks Sidebar, and that item in the sidebar happens to be slightly clipped.

Updated

7 years ago
Duplicate of this bug: 619973
Old bug, WFM in current versions, please reopen if you can reproduce in Firefox 4.0, most likely if this is still broken in 3.5 it won't get a fix since changes are too scary to be backported.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
status1.9.1: --- → wontfix
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.