Window title is corrupted with non-ASCII chars.

VERIFIED WORKSFORME

Status

SeaMonkey
UI Design
P3
normal
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: Screwtape, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I viewed a web page whose <TITLE> contained an accented vowel, and the title
in Mozilla's title bar was badly wrong.

For example, when the title was "Página.de/Eliphas :)", the title bar read "P".
When the title was "ágina.de/Eliphas :)", the title bar read ".agina.de/Eliphas
:) - Mozilla {Build ID: 2000091108}".

For the record, I'm using Helix GNOME 1.2, with Sawfish 0.30.3 as my window
manager on RedHat 6.0. I can set the title of my gnome-terminal to the same
string with no corruption, so I think it's Mozilla's problem.
(Reporter)

Comment 1

18 years ago
OK, I don't know where this came from, but what I *actually* typed in (into
Mozilla, no less) was a lowercase "á", not "Ã" - and I have no idea where the
"!" came from. 

I'm about to attach the testcase file I used. It's got commented-out samples
of a few of these. It also happens for "n-tilde" as well as "á".

Comment 2

18 years ago
Can you add the output of xprop on the affected window? This WFM w/ linux CVS
from 091218. The issuse is probably related to bug 41786 or bug 43108. I am seeing:

WM_NAME(STRING) = "P\341gina.de/Eliphas :) - Mozilla [2000091218 CVS]"

This renders correctly with aewm, twm, and blackbox.
(Reporter)

Comment 3

18 years ago
Well, I'll be danged. With 2000091212, it works fine again.

The only thing I can think of is that yesterday I used a -installer.tar.gz
version, as the usual tarball wasn't available.

If I had time and bandwidth, (33.6K modems suck!) I'd get an installer version
again and try once more.
QA Contact: sairuh → claudius

Comment 4

18 years ago
Since this seems to work for the reporter, I'm going to clean it up with a WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
mass-verifying WorksForMe bugs which haven't changed since 2001.12.31.

set your search string in mail to "EmperorLondoMollari" to filter out these
messages.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.