Can drag hr horizontal rulers, gives weird results

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
15 years ago

People

(Reporter: uamjet602, Assigned: Brade)

Tracking

({helpwanted})

Trunk
Future
helpwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i686; en-US; m18) Gecko/20000910
BuildID:    2000091021

You can drag horizontal rulers, but the drag has no content; if you drop if on
the URL bar, nothing happens (although it is accepted)

Reproducible: Always
Steps to Reproduce:
1.Go to bugzilla.mozilla.org
2.Drag the ruler between 'View Bugs Already Reported Today' and 'show Mozilla
bug no.'
You may need to try a few times to make sure you don't select text and you are
clicking on the right place, otherwise you won't be able to drag.
3.Drop it in the URL bar to see nothing happen, or into the bookmarks sidebar
panel to confuse Mozilla with an empty bookmark

Actual Results:  Drop it in the URL bar:

Nothing happens

Drop it in the bookmarks panel:

A bookmark appears named bookmarks that is hard to remove, because it doesn't
always appear in the bookmarks editor, and doesn't have the 'delete' item in its
context menu.

Expected Results:  Start selecting text from the point clicked

Comment 1

18 years ago
You certainly need a few goes to find the right place to click. So far, I have
failed to do this on the last horizontal line on a page.

Comment 2

18 years ago
future, assigning to brade
Assignee: mjudge → brade
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: --- → Future
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Keywords: helpwanted
(Assignee)

Comment 3

18 years ago
I think this bug is fixed; you shouldn't be getting any content for an hrule so 
the urlbar shouldn't be accepting the drag.  Please reopen this bug if that is 
not true.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: helpwanted
OS: Linux → All
Hardware: PC → All
Resolution: --- → FIXED
Target Milestone: Future → mozilla0.9.1
(Reporter)

Comment 4

18 years ago
I can still drag horizontal rulers with build 2001053021 linux .

If I go to bugzilla.mozilla.org and drag one of the rulers into the url bar, it
pastes: http://bugzilla.mozilla.org/quicksearch.html

However, my complaint was not about being able to drag a ruler into the url bar,
it was about being able to drag a ruler.

I tend to scroll around in web page by clicking in an area without a link and
dragging down. It is annoying to get into a pointless drag and drop situation
when I happen to click on a horizontal bar.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 5

18 years ago
interesting... it seems to work correctly if you drag an hrule from Composer but 
not from Navigator.  I'll have to look into this another time.
Target Milestone: mozilla0.9.1 → mozilla1.0
(Reporter)

Comment 6

17 years ago
Seems to be fixed now.

-> WFM
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

17 years ago
Something doesn't seem right to me.
When I drag an hrule from browser into Composer, I get an error on my console:
  JavaScript error:
  chrome://global/content/nsTransferable.js line 77: supports.data has no 
properties

I'm reopening this bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 8

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 9

17 years ago
changing selection qa to tpreston.
QA Contact: blaker → tpreston
(Reporter)

Comment 10

17 years ago
This is now happening again on linux 2002022121
(Assignee)

Updated

17 years ago
Status: REOPENED → ASSIGNED
Keywords: helpwanted
Target Milestone: mozilla1.0.1 → Future

Comment 11

16 years ago
WFM, 2003030505, Mozilla 1.3 branch, Windows 98. I can't drag an HR anywhere.

Reporter, are you still seeing this problem?

Comment 12

15 years ago
This works with windows Seamonkey build 2004020909. HRs cannot be selected or
dragged.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.