Lacks the ability to use a unique Trash folder for all accounts, as one can do for Sent, Junk, Drafts...

RESOLVED DUPLICATE of bug 492340

Status

--
enhancement
RESOLVED DUPLICATE of bug 492340
9 years ago
7 years ago

People

(Reporter: nospam.pichel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.9.1.4pre) Gecko/20090915 Thunderbird/3.0b4

TB 3b4 doesn't allow in the accounts preferences to use a unique Trash folder as it offers to do for Drafts, Sent, or Junk messages. This leads to a loss of space in the All Folders view pane for example (see attachment). Since I've got many accounts, the Trash icons steal many place for nothing.

As it is implemented on other folders it shouldn't be such a great deal to offer this possibility ?

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 406557 [details]
Screen shot of "All Folders" view in three pane window... with all the trashes
(In reply to comment #0)
> TB 3b4 doesn't allow in the accounts preferences to use a unique Trash folder
> as it offers to do for Drafts, Sent, or Junk messages.

It's false. You can use any EXISTENT folder as "trash folder" via "Move it to this folder" of Server Settings panel.
(Restrictions/problems)
- Existent folder only, because UI is "selection of existent folder".
  So, you need to create folder for trash manually.
- After folder selection, only lowest level name is displayed.
  So, it's impossible to know current selection is "Trash" or "[Gmail]/Trash"
  via the UI. (Improvement is already requested)
- AFAIR, restart of Tb is still needed in some situations to use the selected
  folder as "trash folder" correctly. AFAIR, bug is opened for it.

If you select subfolder as "trash folder", you can gain space at folder pane by collapse of parent folder.
Another way: Use folder view of "Smart Folders".
If you collapse "Trash", you see single "Trash" icon only for all account's "Trash" folder at folder pane.
(Reporter)

Comment 3

9 years ago
Hello, thanks a lot Wada for your very interesting input !

I understand well your first suggestion, and would be happy to apply it... if only I could find the option "When I delete mail, move it to this folder", see the screenshot in next comment. BTW I've found people who found it, it should look like this : http://s3.amazonaws.com/satisfaction-production/s3_images/35011/Picture_4.png (found from this forum : http://getsatisfaction.com/people/jehrler?page=6 (second item from the top)).
Finally I found out why I can't see this option : the concerned accounts are all POP ones, I don't check them via IMAP.
I think POP could benefit from such an option (hidden behind an "Advanced Trash control" button, or added to the "Copies and Folder" along with drafts, sent, and templates folders.

Your second suggestion sounded funny to me because it's the current folder view with which I'm working. This one is almost perfect, but insist on showing an irrelevant list of my accounts, apart from the inbox folders, list I don't know either how to get rid of, since the items (circled in red in the second next graphical comment) have for sole function to show a portal of direct entries for this account. Not really useful for me, and space wasting for sure :-)

I'm wondering if it wouldn't be worth offering the possibility to have a user customized list, eventually mixing regular and smart folders and allowing the user to show and sort what's shown the way he/she wants to ?

Thanks in advance for your following up

Sincerely, 
Michel
(Reporter)

Comment 4

9 years ago
Created attachment 406800 [details]
My server settings view : no "MOve to this folder option" for the Trash action
(Reporter)

Comment 5

9 years ago
Created attachment 406801 [details]
The smart folders view, circled in red : the items I'd like to hide...

Comment 6

9 years ago
only imap accounts can specify trash folders currently.
Oh, you were talking about POP3 account. "Selection of trash folder" is IMAP only option. Sorry for my misunderstanding of this bug.
There are two issues in this bug.
(1) "Folder for trash" is not selectable for POP3/Local Folders.
(2) Trash is not collapsed properly in "Smart Folders" view.

(In reply to comment #5)
> The smart folders view, circled in red : the items I'd like to hide...

I checked with next build, with standard Theme, with no add-on.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20091006 Shredder/3.0pre
Trash is displayed like next with "Smart Folders" view on MS Win.
 (collapsed)
  + Trash
 (expanded)
  - Trash
    trash of account-1
                     |  
    trash of account-N
Do you use non standard Theme or add-on? Does problem occur with -safe-mode?          
Can you check with non-localized build or newer build?
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/
> http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1-l10n/
(Reporter)

Comment 8

9 years ago
(In reply to comment #7)
> Oh, you were talking about POP3 account. "Selection of trash folder" is IMAP
> only option. Sorry for my misunderstanding of this bug.
> There are two issues in this bug.
> (1) "Folder for trash" is not selectable for POP3/Local Folders.
> (2) Trash is not collapsed properly in "Smart Folders" view.

No, not in Smart Folders view, but in "All folders" view (or whatever it's name in english). The Trash in Smart folders view appears as you explain it in the end of your comment, no problem with that.
Just wish I could as you explained in 1) define a single folder for trash so I wouldn't have a folder icon below each inbox in All Folders view.

OR

I could satisfy myself with SmartFolders view if I could find a way to remove from this list all the account entries (the ones inside the red circle in attachment #3 [details] [diff] [review] (link: https://bugzilla.mozilla.org/attachment.cgi?id=406801))
Those list entries aren't very useful since they display only 6 links, 4 of them beeing general commands, the two other having buttons and keyboard shortcuts (new message and read messages)

But I'm afraid I'm going out of the scope of this bug saying that :-)

Michel
(In reply to comment #8)

I understand that your request is "single folder for trash of all(or some) POP3 accounts" rather than "selectable trash for POP3 account".

(WORKAROUND)
Currently, Trash of POP3 account is similar to Inbox of IMAP account;
  Name is fixed. Folder is not selectable. Always one folder per account. 
For Inbox of multiple POP3 accounts, "Global Inbox" was an answer to request of "unified Inbox". It made special folders(trash, drafts, ...) "unified" too.
You can use "Global Inbox" for "unified Trash", because you use POP3 only, if you can afford to:
  - Single account display at folder pane
  - Unified Inbox (Trash is also unified)
  - Unified Sent, Drafts, Templates, Archives, Junk, if standard setup.
  - Some issues due to "Global Inbox"
  - Folder name other than Inbox for arrived mails, if you dislike unified Inbox,
    or if you need "per account folder" for arrived mails.
    You need to move all mails from Inbox to other folder(one per account,
    name is not Inbox) by message filter.
If you use "multiple POP3 accounts definition" as an alternative of "multiple identities", "Global Inbox" can't be a workaround.

(Off-Topic, because out of the scope of this bug)

> OR
> I could satisfy myself with SmartFolders view if I could find a way to remove
> from this list all the account entries

"Collapse of Trash at Smart Folders" is not sufficient for "space problem at folder pane"?
Trash at "Smart Folders" is a virual folder(saved search folder) whose seach target folder is all Trash folders of all accounts(see Folder Properties). And, Trash of each account(real trash folder. see Folder Properties) is displayed by expand at "Smart Folders" view.

Comment 10

8 years ago
Please fix this for ALL cases of [View > Folders].  I want to combine E-mail trash and newsgroup trash into a single Trash folder (with the latter, of course, consisting only of messages I have posted on newsgroups).  

I really do not like the appearance of [View > Folders > Unified] ("smart" folders) and much prefer [View > Folders > All].  Having to switch between the two just to empty my trash is not an acceptable workaround.  

I keep trash for a month.  Daily, I permanently remove any trash that is more than a month old.  Thus, "Empty Trash on Exit" is also not an acceptable workaround.

Comment 11

8 years ago
Since there really is no easy workaround, I have changed the Severity from Minor to Normal.
Severity: minor → normal
It works as designed and implemented. Changing to Enhancement.
Severity: normal → enhancement

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 492340
You need to log in before you can comment on or make changes to this bug.