Reply to all will sometimes put my self as cc in the reply mail

RESOLVED INVALID

Status

RESOLVED INVALID
9 years ago
3 years ago

People

(Reporter: sverre.biseth, Unassigned)

Tracking

({regression})

x86_64
Windows Vista
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; nb-NO; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; nb-NO; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

When you reply to an email, it will be predefined in TB if you get the reply button or the reply to all as default button.
For me it looks like if you receive an email from one person, but the return path is different than the from address you will get the reply to all button - then the next problem is that if I press reply to all TB will create a CC to my self - I dont't want a CC of every mail i reply to.

In my case i have an email sudo sverre.biseth@xxx, but my real address is sverrebi@xx so in this case TB will put a CC since the first is sender and the last is replyer.

How it should work is that the sender and the return path should be considered as one user allways.

Sverre

Reproducible: Always

Steps to Reproduce:
1.Reply to an email that has a different return path than from address
2.Press reply to all
3.TB will now create an email with one receiver and your self as CC
Actual Results:  
Same as above

Expected Results:  
NO CC to your self or just the Reply to button as default

Comment 1

9 years ago
I'm seeing this problem as well.  I'm using Seamonkey 2.0rc2, and this didn't happen in earlier builds (although I can't say specifically which version of Seamonkey is when it started).  

So this is definitely new behavior with a recent Seamonkey/Thunderbird build, and it should be fixed.

FYI, I'm using a self-built x86_64 version of Seamonkey 2.0rc2 on Linux.
Timur can you use our official builds and try to figure out which is the latest version working and which isn't ? (see http://www.rumblingedge.com/2009/02/24/howto-find-regression-windows-through-manual-binary-search/ for more information on how to easily achieve this)

Comment 3

9 years ago
This problem still exists in 2.0.1 on Linux (standard 32-bit release), so please change the platform to "All".

I don't really have the time to track down the specific build where this problem first started.  It's very easy to reproduce, though.

Comment 4

9 years ago
Sverre, do you still see this?

(In reply to comment #3)
> It's very easy to reproduce, though.

but apparently not by everyone (or most). Are you sure you are not already listed as a cc: and a To: in the message you are replying to? Please attach a testcase message.

It is important that someone who can reproduce this finds the regression range. And so far, that means either Sverre or Timur
Keywords: regression, regressionwindow-wanted, testcase-wanted
Version: unspecified → 3.0
(Reporter)

Comment 5

9 years ago
(In reply to comment #4)
> Sverre, do you still see this?
> 
> (In reply to comment #3)
> > It's very easy to reproduce, though.
> 
> but apparently not by everyone (or most). Are you sure you are not already
> listed as a cc: and a To: in the message you are replying to? Please attach a
> testcase message.
> 
> It is important that someone who can reproduce this finds the regression range.
> And so far, that means either Sverre or Timur

Yes, still same issue and no i'm not in CC.
An easy test  if you have facebook just "reply to all" on an email message from them, or an email from bugzilla (I know you are not supposed to but it's an easy test - different sender and reply to address).
I'm now using:
Mozilla/5.0 (Windows; U; Windows NT 6.1; nb-NO; rv:1.9.1.7) Gecko/20100111 Lightning/1.0b1 Thunderbird/3.0.1

Comment 6

9 years ago
(In reply to comment #4)

> but apparently not by everyone (or most). Are you sure you are not already
> listed as a cc: and a To: in the message you are replying to?

Yes, I am in the cc/to of the message.  And this is what triggers the bug.  

Are you implying that if I'm in the to/cc of a message, and I press reply-all, that the reply *should* also be sent to me?  If so, I disagree.  Seamonkey did not do this in the past.  I already have a copy of the email in my "Sent Mail" folder, I do not need another copy in my Inbox.  If I wanted to bcc myself on every sent email, I could enable that feature in the "Mail and Newsgroup Account Settings" dialog box.

Comment 7

9 years ago
Ok, I think I figured out what's going on.  I don't know about what Sverre is seeing, but it appears that when a message is sent to "b04825@freescale.com" (an alias for me), Reply-All includes that email address because Seamonkey thinks that I'm "timur@freescale.com".  Of course, this isn't a bug, it just appears like one to me.

Adding b04825@freescale.com as an alternate identity fixes this problem for me.  I'm not sure why I thought this problem started with a specific version of Seamonkey.  Perhaps it was coincidental to a change in our company email server.

Sverre, could you be seeing the same thing?
(Reporter)

Comment 8

9 years ago
Yes, this is the same as I see - I only see this issue in seamonkey not in Microsoft Outlook, but anyway it fixes the issue adding the alternate identity

Comment 9

9 years ago
I suspect this problem and 543617 are related (both involve confusion over who is "self").

Comment 10

7 years ago
duplicate of bug 523339?

Comment 11

6 years ago
BTW, the multiple identities work-around is not case-insensitive.  That is, if my alternative identity is b04825@freescale.com, then reply-all will still email myself if I received a mail at B04825@freescale.com.  Email addresses are not case-sensitive, so this is a bug, IMHO.
Based on comment 7 and comment 8, this is not a bug -> invalid.
Comment 0 is very confusing.

I understand the following STR

1) In TB, your account is me@asdf.com (without other identities, no reply-to's defined in your account etc.)
2) view msg with following header:
To: my_alias@asdf.com
So my_alias@asdf.com is listed nowhere in your TB account settings
3) Reply-All for msg from step 2

Actual

Reply-all will include my_alias@asdf.com in reply recipients
(because my_alias@asdf.com is an unknown address to TB, listed nowhere in your account settings)

Expected

TB should exclude my_alias@asdf.com from reply recipients???

If my_alias@asdf.com is listed nowhere in TB account settings, how do you expect TB to know it is you?

There's nothing we can do here without a testcase, as requested long ago in Wayne's comment 4 (and a lot more details in note-form if you still think this is a bug).

(In reply to Timur Tabi from comment #11)
> BTW, the multiple identities work-around is not case-insensitive.  That is,
> if my alternative identity is b04825@freescale.com, then reply-all will
> still email myself if I received a mail at B04825@freescale.com.  Email
> addresses are not case-sensitive, so this is a bug, IMHO.

If that still happens, please file a new bug with detailed STR and a testcase message, including explanation of any email addresses listed in account setup, identities etc.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 13

6 years ago
(In reply to Thomas D. from comment #12)

> > BTW, the multiple identities work-around is not case-insensitive.  That is,
> > if my alternative identity is b04825@freescale.com, then reply-all will
> > still email myself if I received a mail at B04825@freescale.com.  Email
> > addresses are not case-sensitive, so this is a bug, IMHO.
> 
> If that still happens, please file a new bug with detailed STR and a
> testcase message, including explanation of any email addresses listed in
> account setup, identities etc.

The case sensitivity issue does not appear to happen any more.  Reply-to-all now works as expected as long as I have multiple identities of all aliases, and it does not matter what case the identities use.

Comment 14

6 years ago
Created attachment 685213 [details]
email source example

There is sufficient information here to perform "Reply all"
The sender should be: dlforkes-friends@yahoo.ca
(from X-Apparently-To)
The To list should be: Frances Sterling <presence1st@gmail.com> Judy Tracey <judytracey@rogers.com>, Stephen Sterling <sjsomega@gmail.com>
(From plus To less X-Apparently-To)
The CC list should be: Linda Allchin <lindarighton@gmail.com>, Jane Grace Bowman <jgb9939@gmail.com>, Jon Reagan <sufijack@sbcglobal.net>, Dennis Bowman <dennis@rightspinhealth.com>, Don Handyside <intheflow@sbcglobal.net>
(CC less X-Apparently-To)

But it doesn't happen. The sender is taken from some other account, and the CC list is unchanged (rather than having X-Apparently-To deleted). Very user unfriendly.

Comment 15

6 years ago
Comment on attachment 685213 [details]
email source example

The result of Reply-To should be obvious from this example:

From dlforkes-friends@yahoo.ca
To Frances Sterling <presence1st@gmail.com> Judy Tracey <judytracey@rogers.com>, Stephen Sterling <sjsomega@gmail.com>
CC Linda Allchin <lindarighton@gmail.com>, Jane Grace Bowman <jgb9939@gmail.com>, Jon Reagan <sufijack@sbcglobal.net>, Dennis Bowman <dennis@rightspinhealth.com>, Don Handyside <intheflow@sbcglobal.net>

But it doesn't happen. The From field is taken from some mysterious place rather than X-Apparently-To, and the CC list does not have X-Apparently-To deleted
Keywords: regressionwindow-wanted, testcase-wanted
You need to log in before you can comment on or make changes to this bug.