Closed Bug 522672 Opened 12 years ago Closed 12 years ago

Can't Uninstall Java Quick Starter

Categories

(Firefox :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 476430

People

(Reporter: samuel, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

I read
http://www.java.com/en/download/help/quickstarter.xml
http://forums.mozillazine.org/viewtopic.php?f=38&t=921325
http://forums.java.net/jive/thread.jspa?threadID=52691&tstart=0
http://khairie.net/remove-java-quick-starter-from-firefox

And I still can't understand why Java Quick Starter has the privilege of not being uninstallable from the Add-ons manager, as every other add-on. I think this behavior is unnecessarily aggressive; in fact i find this nearly malware behavior. Bothering, at least.

So my request is to be strict with this and don't allow Java Quick Starter to "protect itself from users" -or whatever the Sun guys were trying to do- in this way.


Reproducible: Always

Steps to Reproduce:
1. Install Firefox
2. Install Java Runtime Environment
3. Tools > Add-ons > Java Quick Starter
Actual Results:  
Uninstall button is disabled.

Expected Results:  
Uninstall button should be enabled.
I said "from the Add-ons manager, as every other add-on", but I wanted to say: 

from the *Extensions* manager, as every other *extension*
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 476430
You need to log in before you can comment on or make changes to this bug.