Give back the ability to filter folder by text

RESOLVED INVALID

Status

Thunderbird
Search
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Michal Illich, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; cs-CZ; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: 

Hi, new search is nice, but why you disabled the old one?
I'll give you example what's now missing:

* in beta 3, I went to specific folder, typed few letters of the sender's name and it showed me list of mails from that person. That's one click, 3-4 letters and Enter. (If I want to further refine the search, I can easily choose only mails with attachment from the pull-down.) And it all showed in familiar interface, where I can see list of e-mails and the content side-by-side.

* But in beta 4, the closest similar thing is achieved like this: click on search form, type the whole name (or select from suggest), then I must find and click on specific folder, then I must click on sort by date, then I must click on list view. So you forced me to type more and then go through three more steps!

I'm not saying the new search is bad. But the old "filter" was very powerful so it should stay there, because they are two very different things.

You can return it in two ways:
- as a pull-down option in the new search form, labeled for example "quick filter"
- or as a specific design element (form) as it was before


Reproducible: Always

Steps to Reproduce:
1. want to search e-mails from one person in the current folder
2. do too much things described above
3.
Actual Results:  
frustrated user

Expected Results:  
happy user.
One click, type few letters from person's name and see his e-mails (in the same way as in beta 3).
(Reporter)

Comment 1

9 years ago
eh, sorry, this is bogus report, the requested feature already in the pull-down :( I just didn't notice you changed the default.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

9 years ago
Duplicate of this bug: 522711
You need to log in before you can comment on or make changes to this bug.