[AMO] broken link for 'Upload new Version'

VERIFIED FIXED in 5.3

Status

addons.mozilla.org Graveyard
Developer Pages
P3
normal
VERIFIED FIXED
9 years ago
2 years ago

People

(Reporter: vish_moz, Assigned: wenzel)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
Created attachment 406805 [details]
xpi file I used for upload

Steps to reproduce:
1. log into preview.addons.mozilla.org
2. go to https://preview.addons.mozilla.org/en-US/developers/addon/submit
3. Hit Get Started -> Pick any license -> Hit 'Agree & Continue'
4. Upload a addon file (use the one in the attachment)
5. You will get an error saying 'this addon ID already exists in the DB'. CLick on the link below which says 'Upload new Version'

Expected result:
You will be taken to a page that lets you upload new version

Actual result:
You are redirected to https://preview.addons.mozilla.org/en-US/developers/version/add which gives 'Addon Not found'

Screencast:
http://screencast.com/t/rPZtXbD5aJj5
I was thinking that it could get the add-on # from the GUID, no?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 524079
Fred, I originally thought that this was a duplicate of bug 524079, but it seems not.
Status: RESOLVED → REOPENED
OS: Mac OS X → All
Hardware: x86 → All
Resolution: DUPLICATE → ---
Target Milestone: --- → 5.3
(Assignee)

Comment 4

9 years ago
Ah, quite coincidentally, I am fixing this as part of bug 523501. I'll keep it open until that lands.
Assignee: nobody → fwenzel
Status: REOPENED → ASSIGNED
Priority: -- → P3
(Assignee)

Comment 5

9 years ago
This part of bug 523501 has landed, so it's fixed (I just tried it on preview). 

QA: You can just try uploading any existing add-on's file as a new one, which will cause this error.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago9 years ago
Keywords: push-needed
Resolution: --- → FIXED
(Reporter)

Comment 6

9 years ago
Verified, FIXED.
Now uploading an existing addon and then clicking on 'upload new version' gives 'Access Denied' which is correct since I'm not the owner of the addon neither am I an admin.
Status: RESOLVED → VERIFIED
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.