Closed Bug 522865 Opened 13 years ago Closed 10 years ago

Localized CSV datafiles makes Import/Export useless

Categories

(MailNews Core :: Import, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 145293

People

(Reporter: mcepl, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090911 Fedora/3.5.3-1.fc12 Firefox/3.5.3
Build Identifier: thunderbird-3.0-2.7.b4.fc11.i586

In locale ru_RU.UTF-8:
CSV file of address book from thunderbird can not be used for import into
gmail.
CSV file of address book from gmail can not be used for import into
thunderbird.

for export/import thunderbird use localized names of fields (as is), but not
well known standard.

Part of header of google CSV
---
[sergeil@homedesk download]$ head contacts.csv
First Name,Middle Name,Last Name,...
---

Part of header of thunderbird CSV
---
Имя,Фамилия,Отображаемое имя,Псевдоним,Адрес электронной ...
---

PS: KAddressBook can import CSV file from gmail correct.  

Reproducible: Always

Steps to Reproduce:
1. set locale ru_RU.UTF-8
2. run thunderbird
3. export address book from thunderbird and import it into gmail.
4. export address book from gmail and import it into thunderbird.
Actual Results:  
all important fields are imported as blank

Expected Results:  
It should Just Work™
(originally filed as https://bugzilla.redhat.com/show_bug.cgi?id=529476)
For importing into Thunderbird there should be no difference whether the CSV names are localised or not.

Thunderbird doesn't use the first line to detect the names of the fields - the user has to align them manually, additionally there is an option in Thunderbird import to skip the first line.


For the export from Thunderbird and import to gmail, if gmail can't cope with non-english field names, then surely that is a gmail bug and not a Thunderbird bug?

So unless there's an issue with file encoding (which I believe other bugs touch on), I don't see any issues here.
I can confirm this. The problem is that google CSV file is encoded in UTF-16.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 145293
You need to log in before you can comment on or make changes to this bug.