Crash [@FinalizeArenaList<JSString> ], [@arena_dalloc_small | arena_dalloc | free | JSFreePointerListTask::run() ] while pages are loading by middle-click Bookmarks Folder(Open All in Tabs)

RESOLVED DUPLICATE of bug 522775

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 522775
9 years ago
9 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b2pre) Gecko/20091016 Firefox/3.5.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091017 Minefield/3.7a1pre ID:20091017051221

Browser crashes with high probability when I open 20~40 bookmark at a time.

while pages are loading by middle-click Bookmarks Folder(Open All in Tabs), the browser crashes with Crash report.
The bookmarks folder contains more than 20~40 bookmarks.

http://crash-stats.mozilla.com/report/index/ab4a0222-c8ef-4f1b-8c54-0fb512091017?p=1
http://crash-stats.mozilla.com/report/index/c69f6951-8b8d-4f9d-8656-e21ed2091017?p=1

Reproducible: Sometimes

Steps to Reproduce:
1.Start Minefield with new profile
2.Create a Folder on Bookmarks Toolbar.
3.Create Bookmarks http://www.mozilla.org/projects/minefield/  in the Folder
4.Create Bookmarks http://www.mozilla.com/en-US/firefox/central/  in the Folder
5.Duplicate the above bookmarks 10~20times (By using Cut & Past in the LIBRARY) so that we get 20~40 bookmarks in that folder.

6.Middle Click the Folder (Open All in Tabs)
Actual Results:  
Browser crashes while page loading.

Expected Results:  
Browser should not crash
(Reporter)

Updated

9 years ago
Version: unspecified → Trunk
(Reporter)

Comment 1

9 years ago
Namoroka does not crash.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2b2pre) Gecko/20091016 Namoroka/3.6b2pre ID:20091016050535
0  	mozjs.dll  	FinalizeArenaList<JSString>  	 js/src/jsgc.cpp:3249
1 	mozjs.dll 	js_GC 	js/src/jsgc.cpp:3615
2 	mozjs.dll 	RefillFinalizableFreeList 	js/src/jsgc.cpp:1825
3 	mozjs.dll 	NewFinalizableGCThing 	js/src/jsgc.cpp:1920
4 	mozjs.dll 	js_NewStringFromCharBuffer 	js/src/jsstr.cpp:3079
5 	mozjs.dll 	array_toString_sub 	js/src/jsarray.cpp:1571
6 	mozjs.dll 	array_join 	js/src/jsarray.cpp:1800
7 	mozjs.dll 	js_Interpret 	js/src/jsops.cpp:2257
8 	mozjs.dll 	js_Execute 	js/src/jsinterp.cpp:1600
9 	mozjs.dll 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:5054
10 	xul.dll 	nsJSContext::EvaluateString 	dom/base/nsJSEnvironment.cpp:1682
11 	xul.dll 	nsScriptLoader::EvaluateScript 	content/base/src/nsScriptLoader.cpp:686
12 	xul.dll 	nsScriptLoader::ProcessRequest 	content/base/src/nsScriptLoader.cpp:600
13 		@0x1df583 

0  	mozcrt19.dll  	arena_dalloc_small  	 obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4425
1 	mozcrt19.dll 	arena_dalloc 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:4548
2 	mozcrt19.dll 	free 	obj-firefox/memory/jemalloc/crtsrc/jemalloc.c:6387
3 	mozjs.dll 	JSFreePointerListTask::run 	js/src/jsgc.h:371
4 	mozjs.dll 	JSBackgroundThread::work 	js/src/jstask.cpp:96
5 	mozjs.dll 	start 	js/src/jstask.cpp:43
6 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
7 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
8 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
9 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
10 	kernel32.dll 	BaseThreadInitThunk 	
11 	ntdll.dll 	__RtlUserThreadStart 	
12 	ntdll.dll 	_RtlUserThreadStart
Assignee: nobody → general
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 3

9 years ago
Regression range:
Fine:
http://hg.mozilla.org/mozilla-central/rev/db3de2785423
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091016 Minefield/3.7a1pre ID:20091016121124

Broken:
http://hg.mozilla.org/mozilla-central/rev/9224d55364e8
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a1pre) Gecko/20091016 Minefield/3.7a1pre ID:20091016122349

PushLog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=db3de2785423&tochange=9224d55364e8
Keywords: regression

Comment 4

9 years ago
This could be a dup of bug 522775.

Comment 5

9 years ago
(In reply to comment #4)
> This could be a dup of bug 522775.

I landed the fix for this. Let's hope that does the trick.
(Reporter)

Comment 6

9 years ago
I try latest hourly of
http://hg.mozilla.org/mozilla-central/rev/b38391a1f523 .
And the crash does not happen.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522775
You need to log in before you can comment on or make changes to this bug.