Search UI: mail criteria operators not to spec.

VERIFIED DUPLICATE of bug 60514

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED DUPLICATE of bug 60514
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: gayatrib)

Tracking

({regression})

Trunk
Future
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
Using sept 11 commercial build

Seamonkey Search Messages UI spec:
http://gooey/client/5.0/specs/mail/Search/Search.html

The search ui now makes available only Contains/Doesn't Contain as choice of
operators for any text value criteria (Subject,Sender,To,To or Cc).  This is
true for any mail account selection, POP or IMAP.

The spec shows a larger range of choices should be available.  It differs from
the values from 4.x, so I'm not sure what is ultimately correct for 6.0.
Throughout the project it has been told to me that search and filter criteria
would be the same, it is now not -- filters ui does indeed display the
larger/spec'd choices.

When fixed, please reiterate what is correct criteria for news, POP, IMAP and if
offline state should change said choices (I know we're not "officially"
supporting offline, so I would like to know what's the deal here.)
(Reporter)

Comment 1

18 years ago
Nominating nsbeta3. 
Keywords: nsbeta3
QA Contact: esther → laurel

Comment 2

18 years ago
It's too late to be implementing features.  It would be nice to have this, but 
we're not in a mode where we can plus this.  nsbeta3-.
Whiteboard: [nsbeta3-]
Target Milestone: --- → Future

Comment 3

18 years ago
this is not a new feature - it worked quite recently in 6.0, if I understand 
correctly.
Whiteboard: [nsbeta3-]
(Reporter)

Comment 4

18 years ago
Yes, David is correct, it's really a regression. I already talked to Alec about
talking Steve out of the minus.

Comment 5

18 years ago
adding keyword so PDT doesn't assume it's a new feature.
Keywords: regression

Comment 6

18 years ago
I should add it looks like it's actually pulling in the NEWS criteria instea of
the mail criteria (i.e. it isn't that individual criteria have disappeared, it's
just pulling in the wrong set of criteria off the valitity manager)
Status: NEW → ASSIGNED

Comment 7

18 years ago
This does not currently rate a P2, so I can't plus it.  If you would like, we 
can try to build an argument for the PDT to make an exception.  Please come talk 
to me in person if you'd like to do that.
Whiteboard: [nsbeta3-]

Comment 8

18 years ago
reassign all search/filter UI bugs to gayatrib, part 2
Assignee: alecf → gayatrib
Status: ASSIGNED → NEW
(Reporter)

Comment 9

18 years ago
This is really an issue of bug60514. Marking duplicate.

*** This bug has been marked as a duplicate of 60514 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

18 years ago
.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Search → MailNews: Message Display
QA Contact: laurel → search
You need to log in before you can comment on or make changes to this bug.