All users were logged out of Bugzilla on October 13th, 2018

Is there a good way to close background firefox properly?

RESOLVED FIXED

Status

()

P1
major
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: starking, Assigned: vlad)

Tracking

3.6 Branch
ARM
Windows CE
Points:
---
Bug Flags:
blocking-firefox3.6 +

Firefox Tracking Flags

(status1.9.2 beta2-fixed)

Details

(Whiteboard: [nv])

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; WPS; GTB6; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; eSobiSubscriber 2.0.4.16; .NET CLR 3.5.30729; .NET CLR 3.0.30618)
Build Identifier: Mozilla/5.0 WinCE6.0 rv1.9.2a2 Gecko/20090920 Firefox/3.6a2


We've experimented with closing firefox today, but couldn't find a reliable way to do it. 
The firefoxfaststart creates a window with class "MozillaHiddenWindowClas". 
If we send it a WM_DESTROY event it causes it to crash and displays an error message to the user. 
We can call TerminateProcess on it, 
but that doesn't seem like a very good idea because it doesn't give firefox a chance to properly shutdown. 

Reproducible: Always
(Reporter)

Updated

9 years ago
Severity: normal → major
OS: Other → Windows CE
Priority: -- → P2
Hardware: Other → ARM

Updated

9 years ago
Priority: P2 → --
Version: unspecified → 3.6 Branch
Whiteboard: [nv]
Closing the app from File -> Exit will terminate the background FastStart process. Or are you looking for a way to do this from code outside the app?
(Reporter)

Comment 2

9 years ago
Yes, We are looking for a way to do this from code outside the app.
We have an application A.
When A launched, it needs a way to close FastStart process at the same time.
Before A closed, it will launch faststart again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 522625
Un-dup'ing this -- this is a separate issue from bug 522625, where we don't have a message for this.   On the desktop, we use WM_QUERYSESSION/WM_ENDSESSION, but those aren't available on CE.  I'm testing a patch currently that will make WM_QUIT behave like WM_ENDSESSION on CE, in which case sending a WM_QUIT to Firefox should do a safe controlled shutdown.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Assignee: nobody → vladimir
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3.6+
Priority: -- → P1
Created attachment 410374 [details] [diff] [review]
MOZ_WM_APP_QUIT

This defines MOZ_WM_APP_QUIT, which is (WM_APP+0x0300).  It basically signals the app to exit, similar to the desktop QUERYENDSESSION stuff, but that's not available on CE.
Attachment #410374 - Flags: review?
Attachment #410374 - Flags: review? → review?(jmathies)

Updated

9 years ago
Attachment #410374 - Flags: review?(jmathies) → review+
status1.9.2: --- → final-fixed
status1.9.2: final-fixed → beta2-fixed

Comment 7

9 years ago
[Side note: Years ago we used to have a command-line option to do this, so that you could invoke $APP -KillAll to close an existing instance.]
You need to log in before you can comment on or make changes to this bug.