If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Re-enable mac and winmo for electrolysis

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: Benjamin Smedberg, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
We'd like to re-enable the mac and wince builders on Electrolysis, now that the builds should be green there again. This un-does bug 513154.
(Reporter)

Updated

8 years ago
Duplicate of this bug: 523191
I will revert the patch in bug 513154 and run it in staging
Assignee: nobody → jford
(Assignee)

Comment 3

8 years ago
WinMo != WinCE, so it's not a straight revert of bug 513154.

Benjamin, was that a deliberate difference when you filed this ?
(Reporter)

Comment 4

8 years ago
I don't know the difference. I want basic build coverage to make sure that when we land this stuff we don't break the mobile build(s).
(Assignee)

Comment 5

8 years ago
OK. WinCE builds are Firefox, while WinMO is Fennec on XULRunner. Both are compiled using VS2008 rather than 2005, for the Arm architecture. Roughly corresponds to netbooks and phones.
(Reporter)

Comment 6

8 years ago
Since they're building the same basic code/arch, I don't care at all which one is built.
(Assignee)

Comment 7

8 years ago
OK, lets take the shortest path and back out the patch after all. I'll get out of the way now ;-).
Summary: Re-enable mac and wince for electrolysis → Re-enable mac and winmo for electrolysis
Assignee: jford → nthomas
(Assignee)

Comment 8

8 years ago
Created attachment 407454 [details] [diff] [review]
Uncomment a bunch of stuff

buildbot checkconfig is happy with this but I didn't try builds in staging. Let me know if I should do. It's not quite a back out of the original patch due a slight rot.
Attachment #407454 - Flags: review?(catlee)

Updated

8 years ago
Attachment #407454 - Flags: review?(catlee) → review+
(Assignee)

Comment 9

8 years ago
Comment on attachment 407454 [details] [diff] [review]
Uncomment a bunch of stuff

http://hg.mozilla.org/build/buildbot-configs/rev/3d5478d3287c

pm and pm02 reconfig'd, to re-enable these builders:
* OS X 10.5.2 electrolysis build
* OS X 10.5.2 electrolysis nightly
* OS X 10.5.2 electrolysis unit test	
* OS X 10.5.2 electrolysis test mochitests
* OS X 10.5.2 electrolysis test everythingelse
* OS X 10.5.2 electrolysis shark
* OS X 10.5.2 electrolysis leak test build
* WinMo electrolysis build
* WinMo electrolysis nightly

Builds triggered for all the "build", "unit test", and "leak test build".
Attachment #407454 - Flags: checked-in+
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.