Last Comment Bug 523140 - Improve language of "Start New Session" string in about:sessionrestore
: Improve language of "Start New Session" string in about:sessionrestore
Status: RESOLVED FIXED
[good first bug][mentor=zpao]
: ux-error-prevention, ux-jargon
Product: Firefox
Classification: Client Software
Component: Session Restore (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: Firefox 16
Assigned To: Chris Lee (:cleer)
:
:
Mentors:
: 589272 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-19 10:23 PDT by Michael Kohler [:mkohler]
Modified: 2012-07-15 18:00 PDT (History)
14 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Change about improving language has been made. (1.86 KB, patch)
2011-11-10 05:22 PST, pallavi
paul: review-
Details | Diff | Splinter Review
language of "Start New Session" string in about:sessionrestore has been improved (136.58 KB, patch)
2012-03-19 05:10 PDT, pallavi
me: review-
Details | Diff | Splinter Review
Patch (3.15 KB, text/plain)
2012-06-04 18:59 PDT, Chris Lee (:cleer)
no flags Details
Patch (3.15 KB, patch)
2012-06-04 19:02 PDT, Chris Lee (:cleer)
paul: review+
Details | Diff | Splinter Review

Description Michael Kohler [:mkohler] 2009-10-19 10:23:52 PDT
Follow-up of bug 477322.

Mike Beltzner suggested in that bug to rename "Start New Session" to "Close":

> - changing the text of "Start New Session" to "Close" (probably needs a new
> bug so we don't get held up on string freeze)
Comment 1 u88484 2009-10-19 10:31:20 PDT
"Close" is not descriptive and in turn not helpful at all.

I haven't seen this page in a while so I'm going off memory here.  Users are present with a list of tabs and windows that were opened when the browser crashed.  So they can either select the option to "Start New Session" or "Restore Session" (Restore session restores the selected tabs and windows).

Mike, how is "Close" going to let the user know what is going to happen when they close that page?  They are not informed that closing the page will start a new session and their tabs and windows will be lost.  Also, with the tabs and windows having check boxes (Which I think are by default all selected) users may think that instantapply is in effect and those tabs and windows will be restored.
Comment 2 Robin Berjon 2011-03-11 04:48:02 PST
Switching it to "Close" certainly wouldn't help, but it's vital that there be a confirmation dialog for this action. I regularly lose my session because "Start New..." sounds like the right thing to click, and Firefox gives me no chance to fix my mistake before wiping everything out. Just saying "ARE YOU SURE YOU WANT TO WIPE OUT DAYS OF CAREFULLY ACCUMULATED RESEARCH AND CRY FOR AN HOUR AFTERWARDS" in a big scary confirm dialog default to "OMG NO!" should do the trick.
Comment 3 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-03-11 14:02:48 PST
FWIW, you can press the back button after you press "start new session" and then restore your session.
Comment 4 Fred Wenzel [:wenzel] 2011-09-05 14:46:34 PDT
(In reply to Paul O'Shannessy [:zpao] from comment #3)
> FWIW, you can press the back button after you press "start new session" and
> then restore your session.

OMG you can? I did not know that. That's amazing! I lost a complete set of tabs SO MANY TIMES now because I accidentally clicked "start new session" as opposed to "restore", thinking that it would "start a new session" with all my tabs restored! :(((

I wish the session restore did something, anything! To a) make sure the wording implies, clicking this will vaporize all 20 of the 20 tabs in your previous session and b) give me any indication that if I accidentally click this, then I can go back and still restore my session, and I don't need to recreate all my previous tabs from memory because I misclicked once on accident.

Faaborg, any words of wisdom? :)
Comment 5 Fred Wenzel [:wenzel] 2011-09-05 14:47:55 PDT
*** Bug 589272 has been marked as a duplicate of this bug. ***
Comment 6 Alex Faaborg [:faaborg] (Firefox UX) 2011-09-06 16:51:07 PDT
Rewording "start new session" to "close" is fine.  We wanted new to mean "fresh" or "empty" but it looks like people are parsing it as "try again"
Comment 7 Shyam Prasad Murarka 2011-09-10 01:09:07 PDT
Hi,

We could try this alternative.

Below the list of pages that crashed, just give one button that stays "Restore selected pages" and a checkbox beside it (preferably on the left) that says "Deselect All".

Thanks.
Comment 8 Andrew Liu 2011-09-11 12:54:14 PDT
Hello,

I'm interested in taking this as my first bug.

Before I start to work on it, is there a consensus that we simply want to change "Start New Session" to "Close"? If so, then I will start work on it. If not, then here is another suggestion that has two parts:

(1) change "Start New Session" to "Erase session data and start new session". This might make it more clear to the user that the session data will be lost.

(2) make the "Restore" button green, and make the "Erase session data and start new session" button red. This might help direct half-awake users to automatically click on the green button. Even if this is not what they wanted, at least they didn't lose any data.

Please let me know what you think.

Thanks!
Comment 9 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-09-14 11:26:40 PDT
(In reply to Andrew Liu from comment #8)
> Hello,
> 
> I'm interested in taking this as my first bug.
> 
> Before I start to work on it, is there a consensus that we simply want to
> change "Start New Session" to "Close"? If so, then I will start work on it.

I think that's what we're going to do. As of now (well, 2 days ago really) I'm pretty much unavailable to mentor until the first week in October.

I'm CCing Dietrich who I'm sure will be happy to help. Alternatively, you can ask for help in #fx-team on irc.mozilla.org and there are a bunch of people there who can help on the specifics of changing a string.

As a launching point, this link should help: https://mxr.mozilla.org/mozilla-central/search?string=restorepage.cancelButton
Comment 10 Andrew Liu 2011-09-14 11:49:15 PDT
Thanks for getting back to me, Paul, and providing the link. So far it looks like here is what I need to do in mozilla/browser/locales/en-US/chrome/browser/aboutSessionRestore.dtd:

1. change the string for restorepage.cancelButton from "Start New Session" to "Close"
2. change the string for restorepage.cancel.access from "S" to "C"

I wonder if changing the function name from startNewSession() to something else (close()?) is in the scope of this bug.

I will look more into this later.

(In reply to Paul O'Shannessy [:zpao] (away 9/12-10/4) from comment #9)
> (In reply to Andrew Liu from comment #8)
> > Hello,
> > 
> > I'm interested in taking this as my first bug.
> > 
> > Before I start to work on it, is there a consensus that we simply want to
> > change "Start New Session" to "Close"? If so, then I will start work on it.
> 
> I think that's what we're going to do. As of now (well, 2 days ago really)
> I'm pretty much unavailable to mentor until the first week in October.
> 
> I'm CCing Dietrich who I'm sure will be happy to help. Alternatively, you
> can ask for help in #fx-team on irc.mozilla.org and there are a bunch of
> people there who can help on the specifics of changing a string.
> 
> As a launching point, this link should help:
> https://mxr.mozilla.org/mozilla-central/search?string=restorepage.
> cancelButton
Comment 11 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-09-14 11:59:19 PDT
(In reply to Andrew Liu from comment #10)
> Thanks for getting back to me, Paul, and providing the link. So far it looks
> like here is what I need to do in
> mozilla/browser/locales/en-US/chrome/browser/aboutSessionRestore.dtd:
> 
> 1. change the string for restorepage.cancelButton from "Start New Session"
> to "Close"
> 2. change the string for restorepage.cancel.access from "S" to "C"

The other thing that needs to happen (as a byproduct of our L10N process) is that we need to change restorepage.cancelButton (and the other) to something else, like restorePage.closeButton (I liked cancelButton since it's the general format for the type of page, but oh well).

> I wonder if changing the function name from startNewSession() to something
> else (close()?) is in the scope of this bug.

Nah, that's not necessary.
Comment 12 pallavi 2011-11-10 05:22:25 PST
Created attachment 573491 [details] [diff] [review]
Change about improving language has been made.
Comment 13 Andrew Liu 2011-11-10 05:44:11 PST
Sorry I didn't make any progress. Looks like pallavi already has a patch so I'm not going to work on this bug any further. Thanks.
Comment 14 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2011-11-10 10:13:57 PST
Comment on attachment 573491 [details] [diff] [review]
Change about improving language has been made.

Review of attachment 573491 [details] [diff] [review]:
-----------------------------------------------------------------

Hey Pallavi, thanks for jumping in here. It just needs a little bit of tweaking and then it's good to go. Request review from me when you have a new patch up and we'll get this checked in.

::: browser/locales/en-US/chrome/browser/aboutSessionRestore.dtd
@@ -10,5 @@
>  
>  <!ENTITY restorepage.tryagainButton "Restore">
>  <!ENTITY restorepage.restore.access "R">
> -<!ENTITY restorepage.cancelButton   "Start New Session">
> -<!ENTITY restorepage.cancel.access  "S">

Due to the way our localization tools work, we actually need to change the entity names here, so something like restorepage.closeButton and restorepage.close.access probably work best.

You'll need to update aboutSessionRestore.xhtml as well to pick up the new entities names.
Comment 15 Michael Kohler [:mkohler] 2012-01-11 12:07:51 PST
pallavi, are you working on an updated patch?
Comment 16 pallavi 2012-01-12 05:00:55 PST
I was stuck with some priorities past few days.Ya I am up to it now.
Comment 17 pallavi 2012-03-19 05:10:24 PDT
Created attachment 607124 [details] [diff] [review]
language of "Start New Session" string in about:sessionrestore has been improved
Comment 18 Michael Kohler [:mkohler] 2012-03-19 08:12:06 PDT
Comment on attachment 607124 [details] [diff] [review]
language of "Start New Session" string in about:sessionrestore has been improved

The changes you made look good to me at a first glance. Unfortunately the diff didn't work correctly. Could you please upload a patch which diffs only the changes necessary to this bug (without the no-diff changes). After that please request review from Paul O'Shannessy since I'm not a peer.
Comment 19 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-03-19 10:13:53 PDT
Comment on attachment 607124 [details] [diff] [review]
language of "Start New Session" string in about:sessionrestore has been improved

Review of attachment 607124 [details] [diff] [review]:
-----------------------------------------------------------------

You have some extraneous changes in here (README, pageloader.js, report.js). Otherwise I think it looks good. I'll give a new patch a quick review and then it should be good to go.

::: browser/locales/en-US/chrome/browser/aboutSessionRestore.dtd
@@ +10,5 @@
>  
>  <!ENTITY restorepage.tryagainButton "Restore">
>  <!ENTITY restorepage.restore.access "R">
> +<!ENTITY restorepage.closeButton   "Close">
> +<!ENTITY restorepage.close.access  "C">

nit: please add an extra space in there so the quotes all line up.
Comment 20 Chris Lee (:cleer) 2012-06-04 18:59:16 PDT
Created attachment 630035 [details]
Patch

Fixed up pallavi's last patch
Comment 21 Chris Lee (:cleer) 2012-06-04 19:02:54 PDT
Created attachment 630036 [details] [diff] [review]
Patch

Fixed pallavi's last patch

(and forgot to mark as patch the last time)
Comment 22 Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-06-05 00:29:32 PDT
Comment on attachment 630036 [details] [diff] [review]
Patch

Review of attachment 630036 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks Chris!

(In reply to Chris Lee (:cleer) from comment #21)
> (and forgot to mark as patch the last time)

For future reference, you can just go to the attachment details page and mark it as a patch there - no need to upload again.
Comment 23 Tim Taubert [:ttaubert] 2012-06-05 10:22:12 PDT
Will check this in.
Comment 24 Tim Taubert [:ttaubert] 2012-06-05 10:27:20 PDT
https://hg.mozilla.org/integration/fx-team/rev/715f521dd3e2
Comment 25 Tim Taubert [:ttaubert] 2012-06-06 08:41:32 PDT
https://hg.mozilla.org/mozilla-central/rev/715f521dd3e2

Note You need to log in before you can comment on or make changes to this bug.