Investigate conditionally adding |typedef char16_t jschar| (and thus |-std=c++0x|) for supporting compilers

RESOLVED DUPLICATE of bug 895047

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 895047
9 years ago
5 years ago

People

(Reporter: Waldo, Assigned: Waldo)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

9 years ago
Unfortunately it seems U"foobar" tokenizes differently in C++98 and C++0x, so we have to opt the compiler in to compiling with support for Unicode strings, but that problem is surmountable, if complicating.  Being able to print jschar and jschar* would be sweet.
Depends on: 796948
See Also: → bug 895047
We have mozilla/Char16.h which gives us MOZ_UTF16 and char16_t. As an experiment, I #include'd that header and changed the typedef to see who fails:

* HashString(char16_t *) doesn't exist.
* The intl/ API has a mismatch of char16_t versus its internal type. It does allow you to provide a UCHAR_TYPE to specify exactly what you want to make it, though.
* Template helpers in TypeTraits.h don't exist.

Ameliorating these three issues is enough to move on to building xpcom, where the world breaks due to PRUnichar != jschar.

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 895047
You need to log in before you can comment on or make changes to this bug.