All users were logged out of Bugzilla on October 13th, 2018

"Who" column displays recipients instead of the sender in the list of emails window

RESOLVED DUPLICATE of bug 488063

Status

RESOLVED DUPLICATE of bug 488063
9 years ago
9 years ago

People

(Reporter: antti.heikkila, Assigned: mdudziak)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.1) Gecko/20090902 Eudora/3.0b3

In the three pane window, in the list of received emails, the "who" column should display sender instead of to whom it was sent to. Now all the received email is labeled with my name in the "who" column.

Reproducible: Always
Assignee: nobody → mozilla-bugs
Component: Folder and Message Lists → Mail Window
Product: Thunderbird → Penelope
QA Contact: folders-message-lists → mail-window

Comment 1

9 years ago
This is also a problem in the Mac version (MacBook Pro, OS X.5 (Leopard)

Comment 2

9 years ago
Also seen on the Linux version.  This was not the case with v8.0.0b6; it is new to beta 7.  Every folder in every mailbox has been changed--very annoying.

To get the original columns, I need to open the select columns dialog (icon at the right side of the column heading bar) and deselect Who and select Who.  And if that sounds confusing, it's because that's the way the interface is programmed.  Two items labeled Who, and the pop-up tip only tells me to "Click to select columns to display", not if it's the sender or recipient "Who".

BTW, Eudora v7.1.0.9 on Windows did not offer two "Who" columns, just one, and it would be the sender for inbound mail and the recipient for outbound.
(Reporter)

Comment 3

9 years ago
Thanks Carsten, you just made my life quite a bit easier!
-Antti

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488063

Comment 5

9 years ago
(In reply to comment #4)
> 
> *** This bug has been marked as a duplicate of bug 488063 ***

I would just like to make one thing clear:  The behaviour that the OP of bug 488063 described was not what I saw.  He first posted in April of 2009, before the b7 version was released.  The problem described here was something I only saw after upgrading to b7, not before.  It also is independent of the sender, that is _all_ email received is displayed with the recipient (my address) and not the sender in the Who column, unless changed by selecting a different column to display (as I mentioned in my post of 28 Oct).

It seems that bug 488063 has morphed into a duplicate of this bug, but the problems of the OP there I believe were different from those of the OP here.

Of course, I don't care what bug number is used to track this problem, as long as it gets fixed.  I still have about 100 folders to go through, changing the Who column in each (sigh).

Comment 6

9 years ago
Seems like the same outward facing problem, even though it showed up at different times for different people.

There is work going on to fix the Who issues, with a rearchitecture of the way Who is implemented.  See <http://hg.mozilla.org/penelope/rev/fcd20ae8a640> for some changes that have already been checked in.

This should be fixed in the next release, Eudora 8.0b8/Penelope 0.5a5.
You need to log in before you can comment on or make changes to this bug.