Closed Bug 523255 Opened 10 years ago Closed 10 years ago

Sporadic timeout after 385228-1.svg, with "malloc: *** mmap(size=664887296) failed (error code=12) / error: can't allocate region"

Categories

(Core :: Graphics, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 385228

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: intermittent-failure, Whiteboard: [test which aborts the suite])

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1255992265.1255994821.16757.gz
OS X 10.5.2 mozilla-central test everythingelse on 2009/10/19 15:44:25

{
> REFTEST TEST-PASS | file:///builds/buildbot/moz2-slave/mozilla-central-macosx-unittest-everythingelse/build/reftest/tests/gfx/thebes/crashtests/385289-1.xhtml | (LOAD ONLY)
> Mon Oct 19 15:53:47 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: doClip: empty path.
> Mon Oct 19 15:53:48 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: doClip: empty path.
> REFTEST TEST-PASS | file:///builds/buildbot/moz2-slave/mozilla-central-macosx-unittest-everythingelse/build/reftest/tests/gfx/thebes/crashtests/385228-1.svg | (LOAD ONLY)
> Mon Oct 19 15:53:48 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: doClip: empty path.
> Mon Oct 19 15:53:49 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: CGBitmapContextCreateImage: failed to allocate 664929776 bytes.
> Mon Oct 19 15:53:49 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: CGImageCreate: invalid image provider: NULL.
> firefox-bin(847,0xa050ffa0) malloc: *** mmap(size=664887296) failed (error code=12)
> *** error: can't allocate region
> *** set a breakpoint in malloc_error_break to debug
> Mon Oct 19 15:53:49 bm-xserve17.build.mozilla.org firefox-bin[847] <Error>: CGImageCreate: invalid image bits/pixel or bytes/row.
> 
> command timed out: 1200 seconds without output, killing pid 845
}

So we failed while trying to allocate a 634-megabyte block of memory -- that seems odd...
OS: Linux → Mac OS X
Whiteboard: [orange] [test which aborts the suite]
The last test mentioned in the error log is 385228-1.svg:
http://hg.mozilla.org/mozilla-central/file/0d4182d52170/gfx/thebes/crashtests/385228-1.svg

The next test in the manifest (which is presumably what we were loading when we failed?) is 385228-2.svg:
http://hg.mozilla.org/mozilla-central/file/0d4182d52170/gfx/thebes/crashtests/385228-2.svg
Actually, it looks like the bug that these testcases came from (bug 385228) was precisely about this sort of issue -- huge mallocs.

It was resolved as WFM a few days ago, but I think this failure means it's still broken (albeit sporadic).
Blocks: 385228
I'm just duping this to bug 523255 (which I've just reopened).
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 385228
(In reply to comment #3)
> I'm just duping this to bug 523255 (which I've just reopened).
er, make that bug 385228, of course
Whiteboard: [orange] [test which aborts the suite] → [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.