If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

NS_ERROR_FILE_ACCESS_DENIED on nsIRDFRemoteDataSource.Flush

RESOLVED FIXED

Status

MailNews Core
Feed Reader
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Valery Kondakoff, Unassigned)

Tracking

1.9.1 Branch
x86
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5pre) Gecko/20091019 Shredder/3.0pre

Several times a day I'm receiving the following error on Error Console:

Error: [Exception... "Component returned failure code: 0x80520015 (NS_ERROR_FILE_ACCESS_DENIED) [nsIRDFRemoteDataSource.Flush]"  nsresult: "0x80520015 (NS_ERROR_FILE_ACCESS_DENIED)"  location: "JS frame :: chrome://messenger-newsblog/content/Feed.js :: anonymous :: line 457"  data: no]
Source File: chrome://messenger-newsblog/content/Feed.js
Line: 457

If there is smth to do with these issues?
https://bugzilla.mozilla.org/show_bug.cgi?id=376136
https://bugzilla.mozilla.org/show_bug.cgi?id=496825

Reproducible: Always
Valery can you try to identify the feed that is causing this ?
Component: General → Feed Reader
Product: Thunderbird → MailNews Core
QA Contact: general → feed.reader
Version: unspecified → 1.9.1 Branch
(Reporter)

Comment 2

8 years ago
Trying to identify this.
(Reporter)

Comment 3

8 years ago
It seems this exception is not related to one specific feed. I have 5 different feeds and saw this exception on several of them.
(Reporter)

Comment 4

8 years ago
Today I saw this exception when receiving 14 messages from the following feeds: 
http://news.yandex.ru/Moscow/index.rss and
http://news.yandex.ru/Russia/culture.rss
Both of these feeds are saved to one folder: mailbox:///C:/Users/VK/AppData/Roaming/Thunderbird/Profiles/6cplfjc7.default/Mail/Feeds/Яндекс.Новости .

Can this (two feeds in one folder) cause the error?
(In reply to comment #4)
> Today I saw this exception when receiving 14 messages from the following 
> Can this (two feeds in one folder) cause the error?

Yes it could be that you try to flush the first feed whilst trying to write the second.
(Reporter)

Comment 6

8 years ago
The News & Blogs account Disc Space usage is set to 'Don't delete any messages'.
should be confirmed?

Comment 8

6 years ago
likely fixed due to several changes that landed in Tb12/13.  open a new bug if reproducible in current releases.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.