All users were logged out of Bugzilla on October 13th, 2018

check_all_imap_folders_for_new attempts to check "Saved Search" folders

RESOLVED DUPLICATE of bug 525842

Status

RESOLVED DUPLICATE of bug 525842
9 years ago
9 years ago

People

(Reporter: john.bayly, Unassigned)

Tracking

1.8 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.23 (20090812)

When starting Thunderbird with the "check_all_imap_folders_for_new" enabled, thunderbird attempts to the IMAP server for new emails in any "Saved Search" folders.
This results in an error dialog:
The current command did not succed. The mail server responsed: [NONEXISTENT] Mailbox doesn't exist: <folder name>.

Reproducible: Always

Steps to Reproduce:
1. Create new "Saved Search Folder" (The "Search Online" option doesn't affect the behaviour).
2. Enable the "check_all_imap_folders_for_new" in the Config editor.
3. Close Thunderbird & re-open.
Actual Results:  
Thunderbird checks for new email in all folders.

Expected Results:  
Thunderbird should ignore non IMAP folders (eg. Saved Search folders) when checking for new email in all IMAP folders.
Component: Preferences → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: preferences → networking.imap
Version: unspecified → 1.8 Branch
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525842
You need to log in before you can comment on or make changes to this bug.