All user reviews since April for addon NoSquint have vanished

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Public Pages
P3
normal
RESOLVED INVALID
9 years ago
3 years ago

People

(Reporter: Jason Tackaberry, Unassigned)

Tracking

unspecified
4.x (triaged)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.3) Gecko/20090910 Ubuntu/9.04 (jaunty) Shiretoko/3.5.3
Build Identifier: N/A

As of yesterday (2009-10-19) some time, all reviews after April seem to have vanished.  (The review by "Gabriel_92_ITA" for 2009-10-19 was added after the apparent data loss.)

The current review count is 110, but I recall it being in the higher hundreds (perhaps in the 160s, if memory serves).  I believe this data loss has affected the addon's ranking in the Appearance addons section.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 407293 [details]
The reviews page as found in Google cache, showing some of the missing reviews.
Did you happen to remove any add-on version at the time?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 3

9 years ago
Yes, I did delete a version, and it was near the time I noticed the reviews were missing.  However as it's been a while since I submitted the bug and my memory is fuzzy, I can't say with any certainty which event came first.
I'm pretty sure there's a bug somewhere about user reviews being associated to add-on versions, and removing a version will remove all comments as well. I can't seem to find it at the moment, though, so I'll keep this open.

The bottom line is that the reviews can't be recovered, and you should be careful about deleting add-on versions in the future, to prevent this from happening again.
Priority: -- → P3
Target Milestone: --- → 4.x (triaged)
(Reporter)

Comment 5

9 years ago
As an interim measure, perhaps a warning could be displayed when a developer attempts to delete an add-on version.

Comment 6

9 years ago
I was experiencing the same problem, but worse: I changed my addon from hosted to self-hosted and all the reviews disappeared! 
https://addons.mozilla.org/firefox/addon/50072

Other guy was hit by this issue too: he switched from self-hosted to hosted and also lost all his reviews 
https://addons.mozilla.org/uk/firefox/addon/52537
(In reply to comment #6)
> I was experiencing the same problem, but worse: I changed my addon from hosted
> to self-hosted and all the reviews disappeared! 
> https://addons.mozilla.org/firefox/addon/50072

When I click "Change to self-hosted", a block of text comes up that starts "Are you sure you wish to switch to a listed-only add-on? All of your versions and files will be deleted..."

Reviews are attached to versions, and when you delete all your versions, the reviews go with it.

I don't know if we have a similar warning for the other direction.
Bug 557879 is probably going to detach reviews from versions, but there's nothing to do in this bug.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 10

8 years ago
Unless you are denying the cause of the lost reviews is a bug, isn't the proper resolution WONTFIX and not INVALID?
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.