[Regression] _criticalRect is empty and throws in Rect.center()

VERIFIED FIXED in fennec1.0b5

Status

VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: mfinkle, Assigned: stechz)

Tracking

Trunk
fennec1.0b5
x86
Linux
Bug Flags:
in-litmus +

Details

Attachments

(1 attachment, 1 obsolete attachment)

* Go to the Add-on Manager
* Search for an add-on
* Select a returned add-on
* Press "Go to Page" button

"Empty rectangles do not have centers" starts getting thrown from Rect.center()
(Assignee)

Comment 1

9 years ago
Created attachment 407370 [details] [diff] [review]
Fix

Since empty rectangles are possible, criticalRect is now never null.
Assignee: nobody → webapps
Attachment #407370 - Flags: review?(froystig)
(Assignee)

Comment 2

9 years ago
Created attachment 407384 [details] [diff] [review]
Fix missed rectangle checks
Attachment #407384 - Flags: review?(froystig)
(Assignee)

Updated

9 years ago
Attachment #407370 - Attachment is obsolete: true
Attachment #407370 - Flags: review?(froystig)
Comment on attachment 407384 [details] [diff] [review]
Fix missed rectangle checks

This seems to correct all the regressions caused by the issue best described as: "Rect operations no longer give null as a sentinel value meaning 'empty', but instead make a Rect whose isEmpty() method returns true", which is the general statement of the bug filed here.

It's very difficult to be entirely sure that the patch corrects *all* cases where we used to rely on a null value to mean "empty" but no longer can (some cases might be obscure and hidden), but these are at least big common ones, if not all of them.  In particular, it does appear to fix all those associated with the critical rect.
Attachment #407384 - Flags: review?(froystig) → review+
(Assignee)

Updated

9 years ago
tracking-fennec: --- → ?
(Reporter)

Updated

9 years ago
Duplicate of this bug: 523484
(Reporter)

Updated

9 years ago
Duplicate of this bug: 523485
pushed:
https://hg.mozilla.org/mobile-browser/rev/550540aec3bd
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
(Reporter)

Updated

9 years ago
Duplicate of this bug: 523100
verified FIXED on builds:

Mozilla/5.0 (Windows; U; WindowsCE 5.2; en-US; rv:1.9.2b1pre) Gecko/20091021 Fennec/1.0a4pre

and

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091021
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091021
Fennec/1.0b5pre
Status: RESOLVED → VERIFIED
tracking-fennec: ? → ---
Flags: in-litmus?
litmus testcase https://litmus.mozilla.org/show_test.cgi?id=11573 created to regression test this bug.
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.