[Regression] Adding/Removing tabs increases width of tab sidebar

VERIFIED FIXED in fennec1.0b5

Status

Fennec Graveyard
General
--
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: aakashd, Assigned: vingtetun)

Tracking

Fennec 1.1
fennec1.0b5
ARM
Maemo
Bug Flags:
in-litmus +

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Build Id:

Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091020
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091020
Fennec/1.0b5pre

Steps to Reproduce:
1. Slide to open the tab sidebar
2. Create a new tab
3. Remove that tab

Actual Results:
On the n810 and n900 on both trunk and 1.9.2 nightly builds, the sidebar incerase in width when adding/removing a tab 

Expected Results: 
The tab sidebar shouldn't increase in width
hmm, each time I add a tab the sidebar gets a little bigger.
Duplicate of this bug: 523161
Duplicate of this bug: 523100
Created attachment 407529 [details] [diff] [review]
patch

Use the same size for tabs than moz-column-size
Attachment #407529 - Flags: review?(mark.finkle)
Attachment #407529 - Flags: review?(mark.finkle) → review+
but we need it for winmo too, right?
(In reply to comment #6)
> but we need it for winmo too, right?

Nope. The display:block which is the root cause of the problem has landed only on maemo for now.

However it is important to not forget it during the resolution of bug 523218.
pushed:
https://hg.mozilla.org/mobile-browser/rev/04164598a4a5
Assignee: nobody → 21
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → B5
(Reporter)

Comment 9

8 years ago
Sweet, verified FIXED on builds:


Mozilla/5.0 (X11; U; Linux armv7l; en-US; rv:1.9.2b1pre) Gecko/20091022
Fennec/1.0b5pre

and

Mozilla/5.0 (X11; U; Linux armv6l; en-US; rv:1.9.3a1pre) Gecko/20091022
Fennec/1.0b5pre
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

8 years ago
Tabbed Browsing regression testcase needed in litmus
Flags: in-litmus?
(Reporter)

Comment 11

8 years ago
litmus testcases 7118 and 7379 have been updated for regression testing this bug.
Flags: in-litmus? → in-litmus+

Updated

8 years ago
Component: Linux/Maemo → General
QA Contact: maemo-linux → general
You need to log in before you can comment on or make changes to this bug.