Moz crased when downloading list of newsgroups.

VERIFIED DUPLICATE of bug 54491

Status

MailNews Core
Networking: NNTP
P3
major
VERIFIED DUPLICATE of bug 54491
18 years ago
10 years ago

People

(Reporter: blockcipher, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000912
BuildID:    2000091212

Mozilla crashes when it is done, or very close to being done, downloading the
list of newsgroups on the server.  Nothing unusual about what I did from what I
can tell.  Has worked with several prior builds.

Reproducible: Always
Steps to Reproduce:
1.Set up newsgroup account.
2.Right click on newsgroup server
3.Select subscribe
4.Wait for Moz to finished downloading newgroup names.

Actual Results:  Mozilla crashed.

Expected Results:  Mozilla should have displayed newsgroup listing.

Here is the crash data:

MOZILLA caused an invalid page fault in
module XPCOM.DLL at 018f:60cfd97e.
Registers:
EAX=0065006e CS=018f EIP=60cfd97e EFLGS=00010216
EBX=03fbb690 SS=0197 ESP=0068cb6c EBP=0068cbac
ECX=0460d6b8 DS=0197 ESI=0460d6b8 FS=5127
EDX=045fcd3c ES=0197 EDI=0068cbbc GS=0000
Bytes at CS:EIP:
ff 50 04 89 45 0c 8b 07 8b cf ff 50 04 3b 45 0c
Stack dump:
03fbb690 045fccd0 03fbb690 bff88dc4 006a0000 00008004 00000000 0068cbc4 78001385
006a0000 00000000 00008000 00000000 00001000 007b4a20 60cf4a79

Updated

18 years ago
QA Contact: esther → suresh
which new server are you testing against?
(Reporter)

Comment 2

18 years ago
The newsgroup server I use is news.nb.net.  Please use this only for testing.

Btw: Tried again with 091908 and it still crashed.
news.nb.net requires a username and password, so I can't log in to reproduce
this.

It's a typhoon server "Powered by Slurp News (Typhoon v1.1.8)".

accepting while I investigate.
Status: NEW → ASSIGNED
you mentioned that the crash happens when it is done, or almost done.
perhaps the number of newsgroups on that server causes the crash.

can you send me the hostinfo.dat file for this server?

since 5.0 is crashing on you, can you send me the hostinfo.dat for this server
from 4.x?

on win98, it would be something like
c:\Program Files\Netscape\Users\<profilename>\News\host-news.nb.net\hostinfo.dat

if it is too big of an attachment for bugzilla, you can email it to me directly
(sspitzer@netscape.com)
(Reporter)

Comment 5

18 years ago
Created attachment 15379 [details]
Hosinfo.dat for news.nb.net

Comment 6

18 years ago
*** Bug 59167 has been marked as a duplicate of this bug. ***

*** This bug has been marked as a duplicate of 54491 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Marking verified as a duplicate
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.