spreadfirefox.com redirects to intlstore.mozilla.org

VERIFIED FIXED

Status

mozilla.org Graveyard
Server Operations
--
major
VERIFIED FIXED
8 years ago
3 years ago

People

(Reporter: tomer, Assigned: XioNoX)

Tracking

Details

(URL)

(Reporter)

Description

8 years ago
When I access spreadfirefox.com, I get redirected to https://intlstore.mozilla.org. It seems like a mod_rewrite failure, as it does redirect spreadfirefox.com/(.*) to https://intlstore.mozilla.org/$1. 


$ curl -I http://spreadfirefox.com/
HTTP/1.1 301 Moved Permanently
Date: Wed, 21 Oct 2009 07:34:46 GMT
Server: Apache/2.2.3 (Red Hat)
Location: http://www.spreadfirefox.com/
Content-Type: text/html; charset=iso-8859-1

$ curl -I http://www.spreadfirefox.com/
HTTP/1.1 301 Moved Permanently
Content-Type: text/html
Date: Wed, 21 Oct 2009 07:33:26 GMT
Location: https://intlstore.mozilla.org/
Connection: Keep-Alive
Content-Length: 0
WFM in en-US; must be some .htaccess or locale-specific thing.

Tomer, what's your accept language (locale) set to?
(Reporter)

Comment 2

8 years ago
I am not sure if it is actually a locale-specifc problem, as I can reproduce using curl, and curl doesn't seem to send such header. 



$ curl -v -I www.spreadfirefox.com/
* About to connect() to www.spreadfirefox.com port 80 (#0)
*   Trying 63.245.213.51... connected
* Connected to www.spreadfirefox.com (63.245.213.51) port 80 (#0)
> HEAD / HTTP/1.1
> User-Agent: curl/7.18.2 (i486-pc-linux-gnu) libcurl/7.18.2 OpenSSL/0.9.8e zlib/1.2.3.3 libidn/1.8
> Host: www.spreadfirefox.com
> Accept: */*
> 
< HTTP/1.1 301 Moved Permanently
HTTP/1.1 301 Moved Permanently
< Content-Type: text/html
Content-Type: text/html
< Date: Wed, 21 Oct 2009 08:08:25 GMT
Date: Wed, 21 Oct 2009 08:08:25 GMT
< Location: https://intlstore.mozilla.org/
Location: https://intlstore.mozilla.org/
< Connection: Keep-Alive
Connection: Keep-Alive
< Content-Length: 0
Content-Length: 0

< 
* Connection #0 to host www.spreadfirefox.com left intact
* Closing connection #0
mrz, something IT could look into?  Is this potential fallout from the move to GLB (http://blog.mozilla.com/it/2009/10/20/mozilla-scheduled-downtime-10202009-9pm-11pm-pdt-0400-0600-10212009-utc/).
(Presumably, because of GLB, I'm getting sent to sfx.glb.mozilla.net[63.245.209.35], which is different than Tomer's.)
Assignee: nobody → server-ops
Component: spreadfirefox.com → Server Operations
OS: Linux → All
Product: Websites → mozilla.org
QA Contact: spreadfirefox-com → mrz
Hardware: x86 → All
Version: unspecified → other
Severity: normal → major
Tomer,

When you do a host spreadfirefox.com and www.spreadfirefox.com, what do you get?
Because, I certainly can't reproduce this :

trinity:~ shyam$ curl -I spreadfirefox.com
HTTP/1.1 301 Moved Permanently
Date: Wed, 21 Oct 2009 10:50:12 GMT
Server: Apache/2.2.3 (Red Hat)
Location: http://www.spreadfirefox.com/
Content-Type: text/html; charset=iso-8859-1

trinity:~ shyam$ curl -I www.spreadfirefox.com
HTTP/1.1 200 OK
Date: Wed, 21 Oct 2009 10:50:18 GMT
Server: Apache/2.2.3 (Red Hat)
X-Powered-By: PHP/5.2.9
Set-Cookie: SESS87e0ebad69a4aed8882ca39d9e840c5d=pkonc0s06lrhvtv0ct014o9kh6; expires=Fri, 13-Nov-2009 14:23:38 GMT; path=/; domain=.spreadfirefox.com
Expires: Sun, 19 Nov 1978 05:00:00 GMT
Last-Modified: Wed, 21 Oct 2009 10:50:18 GMT
Cache-Control: store, no-cache, must-revalidate
Cache-Control: post-check=0, pre-check=0
Content-Type: text/html; charset=utf-8
(Reporter)

Comment 7

8 years ago
tomer@tomer-desktop:~$ host spreadfirefox.com
spreadfirefox.com has address 63.245.209.35
spreadfirefox.com mail is handled by 10 dm-mail02.mozilla.org.
spreadfirefox.com mail is handled by 10 dm-mail01.mozilla.org.

tomer@tomer-desktop:~$ host www.spreadfirefox.com
www.spreadfirefox.com is an alias for www-spreadfirefox-com.geo.mozilla.com.
www-spreadfirefox-com.geo.mozilla.com is an alias for sfx.glb.mozilla.net.
sfx.glb.mozilla.net has address 63.245.213.52
sfx.glb.mozilla.net has address 63.245.213.51



tomer@tomer-desktop:~$ curl -I www.spreadfirefox.com
HTTP/1.1 301 Moved Permanently
Content-Type: text/html
Date: Wed, 21 Oct 2009 11:18:12 GMT
Location: https://intlstore.mozilla.org/
Connection: Keep-Alive
Content-Length: 0


tomer@tomer-desktop:~$ curl -I www-spreadfirefox-com.geo.mozilla.com
HTTP/1.1 301 Moved Permanently
Content-Type: text/html
Date: Wed, 21 Oct 2009 11:29:14 GMT
Location: https://intlstore.mozilla.org/
Connection: Keep-Alive
Content-Length: 0
(Reporter)

Comment 8

8 years ago
For the record, I'm in Israel, and I can reproduce this behavior on some other machines in the local network.

Comment 9

8 years ago
it happens to me too.

Comment 10

8 years ago
Confirmed from Berlin.

workbook:python2.5 axelhecht$ dig spreadfirefox.com

; <<>> DiG 9.4.3-P3 <<>> spreadfirefox.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 36940
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 3, ADDITIONAL: 3

;; QUESTION SECTION:
;spreadfirefox.com.		IN	A

;; ANSWER SECTION:
spreadfirefox.com.	190	IN	A	63.245.209.35

;; AUTHORITY SECTION:
spreadfirefox.com.	190	IN	NS	ns2.mozilla.org.
spreadfirefox.com.	190	IN	NS	ns3.mozilla.org.
spreadfirefox.com.	190	IN	NS	ns1.mozilla.org.

;; ADDITIONAL SECTION:
ns1.mozilla.org.	384	IN	A	63.245.208.161
ns2.mozilla.org.	562	IN	A	140.211.166.194
ns3.mozilla.org.	562	IN	A	63.245.212.5

;; Query time: 25 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Oct 21 13:57:50 2009
;; MSG SIZE  rcvd: 164

workbook:python2.5 axelhecht$ host spreadfirefox.com
spreadfirefox.com has address 63.245.209.35
spreadfirefox.com mail is handled by 10 dm-mail01.mozilla.org.
spreadfirefox.com mail is handled by 10 dm-mail02.mozilla.org.
workbook:python2.5 axelhecht$ host www.spreadfirefox.com
www.spreadfirefox.com is an alias for www-spreadfirefox-com.geo.mozilla.com.
www-spreadfirefox-com.geo.mozilla.com is an alias for sfx.glb.mozilla.net.
sfx.glb.mozilla.net has address 63.245.213.51
sfx.glb.mozilla.net has address 63.245.213.52
workbook:python2.5 axelhecht$ host intlstore.mozilla.org
intlstore.mozilla.org has address 85.13.206.217
workbook:python2.5 axelhecht$ dig www.spreadfirefox.com

; <<>> DiG 9.4.3-P3 <<>> www.spreadfirefox.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 46167
;; flags: qr rd ra; QUERY: 1, ANSWER: 4, AUTHORITY: 2, ADDITIONAL: 0

;; QUESTION SECTION:
;www.spreadfirefox.com.		IN	A

;; ANSWER SECTION:
www.spreadfirefox.com.	403	IN	CNAME	www-spreadfirefox-com.geo.mozilla.com.
www-spreadfirefox-com.geo.mozilla.com. 2547 IN CNAME sfx.glb.mozilla.net.
sfx.glb.mozilla.net.	255	IN	A	63.245.213.52
sfx.glb.mozilla.net.	255	IN	A	63.245.213.51

;; AUTHORITY SECTION:
glb.mozilla.net.	93	IN	NS	ns4-glb.mozilla.net.
glb.mozilla.net.	93	IN	NS	ns1-glb.mozilla.net.

;; Query time: 22 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Oct 21 13:59:01 2009
;; MSG SIZE  rcvd: 196

workbook:python2.5 axelhecht$ wget -O /dev/null http://spreadfirefox.com
--2009-10-21 13:59:31--  http://spreadfirefox.com/
Auflösen des Hostnamen »spreadfirefox.com«.... 63.245.209.35
Verbindungsaufbau zu spreadfirefox.com|63.245.209.35|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 301 Moved Permanently
Platz: http://www.spreadfirefox.com/[folge]
--2009-10-21 13:59:31--  http://www.spreadfirefox.com/
Auflösen des Hostnamen »www.spreadfirefox.com«.... 63.245.213.52, 63.245.213.51
Verbindungsaufbau zu www.spreadfirefox.com|63.245.213.52|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 301 Moved Permanently
Platz: https://intlstore.mozilla.org/[folge]
--2009-10-21 13:59:31--  https://intlstore.mozilla.org/
Auflösen des Hostnamen »intlstore.mozilla.org«.... 85.13.206.217
Verbindungsaufbau zu intlstore.mozilla.org|85.13.206.217|:443... verbunden.
FEHLER: Kann das Zertifikat von »intlstore.mozilla.org« nicht prüfen, ausgestellt von »/C=US/O=SecureTrust Corporation/CN=SecureTrust CA«:.
  Die Authorität des Ausstellers des Zertifikates kann lokal nicht geprüft werden.
Verwenden Sie »--no-check-certificate«, um zu dem Server »intlstore.mozilla.org« eine nicht gesicherte Verbindung aufzubauen.
Es ist nicht möglich, eine SSL-Verbindung herzustellen.
workbook:python2.5 axelhecht$ wget -O /dev/null http://www.spreadfirefox.com
--2009-10-21 13:59:38--  http://www.spreadfirefox.com/
Auflösen des Hostnamen »www.spreadfirefox.com«.... 63.245.213.52, 63.245.213.51
Verbindungsaufbau zu www.spreadfirefox.com|63.245.213.52|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 301 Moved Permanently
Platz: https://intlstore.mozilla.org/[folge]
--2009-10-21 13:59:38--  https://intlstore.mozilla.org/
Auflösen des Hostnamen »intlstore.mozilla.org«.... 85.13.206.217
Verbindungsaufbau zu intlstore.mozilla.org|85.13.206.217|:443... verbunden.
FEHLER: Kann das Zertifikat von »intlstore.mozilla.org« nicht prüfen, ausgestellt von »/C=US/O=SecureTrust Corporation/CN=SecureTrust CA«:.
  Die Authorität des Ausstellers des Zertifikates kann lokal nicht geprüft werden.
Verwenden Sie »--no-check-certificate«, um zu dem Server »intlstore.mozilla.org« eine nicht gesicherte Verbindung aufzubauen.
Es ist nicht möglich, eine SSL-Verbindung herzustellen.
(Assignee)

Comment 11

8 years ago
Should be fixed now for http and https.
The problem was a bad destination IP in the zeus.
Assignee: server-ops → ayounsi
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

8 years ago
(In reply to comment #11)
> Should be fixed now for http and https.
> The problem was a bad destination IP in the zeus.

I can confirm it is now fixed. 

tomer@tomer-desktop:~$ curl -I www.spreadfirefox.com
HTTP/1.1 200 OK
Server: Apache/2.2.3 (Red Hat)
Vary: Accept-Encoding
Cache-Control: max-age=21600
Content-Type: text/html; charset=utf-8
Date: Wed, 21 Oct 2009 15:35:52 GMT
Expires: Sun, 19 Nov 1978 05:00:00 GMT
Transfer-Encoding: chunked
Connection: Keep-Alive
Set-Cookie: SESS87e0ebad69a4aed8882ca39d9e840c5d=nbhh4gopqavn39hdr2cnkgegv5; expires=Fri, 13-Nov-2009 19:09:12 GMT; path=/; domain=.spreadfirefox.com
Last-Modified: Wed, 21 Oct 2009 15:35:53 GMT
X-Powered-By: PHP/5.2.9
X-Cache-Info: caching
Axel, Tsahi: fixed for you guys too?

Comment 14

8 years ago
works fine, except that the SSL is broken on https. it indicates that some parts of the page are not encrypted. also, https://spreadfirefox.com redirects to http://www.spreadfirefox.com (i.e. to a non-encrypted version).
Not fixed for me.

I cannot get to http://www.spreadfirefox.com/ without being redirected to the international store.

I can however get to specific pages, and nodes at least all the ones I tried.
The above it might not be clear: basically only the homepage gets redirected, all other pages don't. So there is still a problem.
I removed a rule that was forcing all content into the cache and purged the cache in Amsterdam.
Thanks matthew, that seems to have helped, I just managed to load the homepage.
Sounds like this is fixed for everyone; verified.
Status: RESOLVED → VERIFIED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.