firefox exits unexpectedly without any crash reports

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: jdryburn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; InfoPath.1; .NET CLR 3.0.04506.648; InfoPath.2; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Build Identifier: 3.5.3

Firefox 3.5.3 (and subsequent pre-releases, including 3.7 prerelease built on my laptop) exits when entering a new URL. It happens in safe mode and with a clean, new profile. 

Reproducible: Always

Steps to Reproduce:
1.Open firefox
2.Open a new tab
3.Enter a web site
Actual Results:  
This usually takes only a few minutes. Sometimes I can get to 3 or 4 different URL's without an exit but every time I use firefox it exits automatically and unexpectedly while loading a web site. The most recent test took 4 tries, finally firefox exited while logging in to gmail. It has done the same connecting to imdb.com, my.yahoo.com, or even www.google.com

Expected Results:  
The browser should continue working with 2 tabs and any number of URL's

I'm pasting in the debug log from WinDbg. It does not consider this exit to be an exception. I have no firewall enabled, I am up to date on Windows XP patches and other updates, and this only began within the last two months.

Opened log file 'c:\firefox-debug_1208_2009-10-21_09-09-26-637.log'
0:000> .childdbg 1
Processes created by the current process will be debugged
0:000> .tlist
    0n0 System Process
    0n4 System
 0n1700 smss.exe
 0n1748 csrss.exe
 0n1776 winlogon.exe
 0n1820 services.exe
 0n1832 lsass.exe
 0n1988 svchost.exe
  0n148 svchost.exe
  0n244 svchost.exe
  0n428 EvtEng.exe
  0n480 S24EvMon.exe
  0n576 svchost.exe
  0n656 svchost.exe
  0n932 ccEvtMgr.exe
  0n980 ccSetMgr.exe
 0n1296 explorer.exe
 0n1364 SPBBCSvc.exe
 0n1624 spoolsv.exe
 0n2016 scardsvr.exe
  0n408 svchost.exe
  0n544 GoogleCrashHandler.exe
  0n772 arr_isrv.exe
  0n452 AppleMobileDeviceService.exe
  0n896 arr_srvs.exe
 0n1144 mDNSResponder.exe
 0n1544 cvpnd.exe
 0n1408 DefWatch.exe
 0n2072 dsNcService.exe
 0n2124 ctfmon.exe
 0n2188 jqs.exe
 0n2600 mdm.exe
 0n2664 MyDesktopService.exe
 0n2860 svchost.exe
 0n2968 nsverctl.exe
 0n3032 ocautoupds.exe
 0n3276 nmz.exe
 0n3348 TaskSwitch.exe
 0n3444 iclient.exe
  0n704 ZCfgSvc.exe
  0n828 iFrmewrk.exe
 0n1064 quickset.exe
 0n1720 Apoint.exe
 0n2488 realsched.exe
 0n2580 ApMsgFwd.exe
 0n2808 ApntEx.exe
 0n2784 hidfind.exe
 0n2672 RDVCHG.exe
 0n2872 iTunesHelper.exe
 0n2996 hkcmd.exe
 0n3016 igfxpers.exe
 0n3128 svchost.exe
 0n3192 jusched.exe
 0n3108 igfxsrvc.exe
 0n3504 MyDesktopQOS.exe
  0n864 ccApp.exe
 0n3684 VPTray.exe
 0n3692 WinPatrol.exe
 0n3804 RegSrvc.exe
 0n3964 msmsgs.exe
 0n3980 SavRoam.exe
 0n4080 Skype.exe
  0n748 btdna.exe
 0n2520 SPCSUtilityService.exe
 0n2696 sqlwriter.exe
 0n1516 VideoAccelerator.exe
 0n2476 svchost.exe
 0n2920 GoogleUpdate.exe
 0n2980 Rtvscan.exe
 0n2224 SUPERAntiSpyware.exe
 0n3268 GoogleCrashHandler.exe
 0n3940 PowerMenu.exe
 0n3932 VideoAcceleratorService.exe
 0n4016 ViewpointService.exe
 0n4044 XobniService.exe
 0n4428 VideoAcceleratorEngine.exe
 0n5052 vsmon.exe
 0n5172 iPodService.exe
 0n5336 winvnc4.exe
 0n5672 alg.exe
 0n5204 Dot1XCfg.exe
 0n5784 skypePM.exe
  0n816 OUTLOOK.EXE
 0n5944 cmd.exe
 0n5940 windirstat.exe
 0n1880 iexplore.exe
 0n1728 iexplore.exe
 0n4588 CineTray.exe
 0n5916 notepad++.exe
 0n5480 iexplore.exe
 0n5236 iexplore.exe
 0n2288 bash.exe
 0n1452 msiexec.exe
 0n4616 windbg.exe
 0n5264 firefox.exe
 0n4100 firefox.exe
0:000> sxn gp
0:000> lm
start    end        module name
00280000 002ec000   sqlite3    (private pdb symbols)  c:\symbols\sqlite3.pdb\555255959B1B4EF38AD174DEB0E456B81\sqlite3.pdb
002f0000 003d4000   js3250     (private pdb symbols)  c:\symbols\js3250.pdb\5FA11BF4F4724630BF24460CB83EF1A32\js3250.pdb
003e0000 003f8000   smime3     (private pdb symbols)  c:\symbols\smime3.pdb\ECA3CFB3B07142628F2CBC288336A2CD1\smime3.pdb
00400000 004df000   firefox    (private pdb symbols)  c:\symbols\firefox.pdb\15F74A40F5A046A79888A361921B47B12\firefox.pdb
004e0000 00509000   nspr4      (private pdb symbols)  c:\symbols\nspr4.pdb\3B236A5359A24547A3CB7AE1D166D7281\nspr4.pdb
00510000 005aa000   nss3       (private pdb symbols)  c:\symbols\nss3.pdb\6CB5117C8B8746D996DB8D82B493FE9C1\nss3.pdb
005b0000 005c4000   nssutil3   (private pdb symbols)  c:\symbols\nssutil3.pdb\D811CD6175AF48A9B274144F4E0997231\nssutil3.pdb
005d0000 005d7000   plc4       (private pdb symbols)  c:\symbols\plc4.pdb\A381741BEAF54415A5903E34023D07421\plc4.pdb
005e0000 005e7000   plds4      (private pdb symbols)  c:\symbols\plds4.pdb\EEB736169DFA490493CD9C029741A0161\plds4.pdb
005f0000 00610000   ssl3       (private pdb symbols)  c:\symbols\ssl3.pdb\66E3D4CE1EA247348BA4F3D001EAC0721\ssl3.pdb
00610000 00617000   xpcom      (private pdb symbols)  c:\symbols\xpcom.pdb\CEA15912EF5F45039991982B0683F9822\xpcom.pdb
10000000 10a5c000   xul        (private pdb symbols)  c:\symbols\xul.pdb\6D7993A52C04439E8F23CBB48F8A7D2E2\xul.pdb
71aa0000 71aa8000   WS2HELP    (pdb symbols)          c:\symbols\ws2help.pdb\6049CF5877C54E2AB512ABC1B4B2E7992\ws2help.pdb
71ab0000 71ac7000   WS2_32     (pdb symbols)          c:\symbols\ws2_32.pdb\A7605F8695A34329B38DDB8421A004CA2\ws2_32.pdb
71ad0000 71ad9000   WSOCK32    (pdb symbols)          c:\symbols\wsock32.pdb\2B38FE8F84144DACB8A4FD07C05E49FC2\wsock32.pdb
73000000 73026000   WINSPOOL   (pdb symbols)          c:\symbols\winspool.pdb\5199B63B39904A05A517CEE5158071522\winspool.pdb
74d90000 74dfb000   USP10      (pdb symbols)          c:\symbols\usp10.pdb\0F289BC0C9A94139BC1C31EDEDBF52311\usp10.pdb
76380000 76385000   MSIMG32    (pdb symbols)          c:\symbols\msimg32.pdb\D2E18526D8234F4BB5A85DE12E71DE812\msimg32.pdb
76390000 763ad000   IMM32      (pdb symbols)          c:\symbols\imm32.pdb\F7A5B5DB13324153B57AAF340C77EA512\imm32.pdb
763b0000 763f9000   COMDLG32   (pdb symbols)          c:\symbols\comdlg32.pdb\026A6FF770FD4E6186ADBBE96DFFA99C2\comdlg32.pdb
76b40000 76b6d000   WINMM      (pdb symbols)          c:\symbols\winmm.pdb\90FC96D5AD8440A2B14855895BD92ED62\winmm.pdb
77120000 771ab000   OLEAUT32   (pdb symbols)          c:\symbols\oleaut32.pdb\F2A209009B694EFCAD1A6CE9D992EBC12\oleaut32.pdb
773d0000 774d3000   COMCTL32   (pdb symbols)          c:\symbols\MicrosoftWindowsCommon-Controls-6.0.2600.5512-comctl32.pdb\505057971C40416FB39FED1D39BED0571\MicrosoftWindowsCommon-Controls-6.0.2600.5512-comctl32.pdb
774e0000 7761d000   ole32      (pdb symbols)          c:\symbols\ole32.pdb\ED517599D2C14CF19200861833059C142\ole32.pdb
77c00000 77c08000   VERSION    (pdb symbols)          c:\symbols\version.pdb\EA3D1BD3FE65475C8449C8D8B00722962\version.pdb
77c10000 77c68000   msvcrt     (pdb symbols)          c:\symbols\msvcrt.pdb\7BCF30D8C91B4F1B85FA4E55896250111\msvcrt.pdb
77dd0000 77e6b000   ADVAPI32   (pdb symbols)          c:\symbols\advapi32.pdb\F759D3F1C6614313B07C84BC33F02E4D2\advapi32.pdb
77e70000 77f02000   RPCRT4     (pdb symbols)          c:\symbols\rpcrt4.pdb\EC95CBF6C6834027AE389DEBCE5F38332\rpcrt4.pdb
77f10000 77f59000   GDI32      (pdb symbols)          c:\symbols\gdi32.pdb\372C0F0E08FB456EAB7B4CB2B53E27952\gdi32.pdb
77f60000 77fd6000   SHLWAPI    (pdb symbols)          c:\symbols\shlwapi.pdb\8519E3403447478884CFFE7F1A91BAE02\shlwapi.pdb
77fe0000 77ff1000   Secur32    (pdb symbols)          c:\symbols\secur32.pdb\7867B3F28B5C41CE847895E3FC013DC52\secur32.pdb
78130000 781e1000   MOZCRT19   (private pdb symbols)  c:\symbols\mozcrt19.pdb\BA376AEDB4094BDC8508D8E9A1C563121\mozcrt19.pdb
7c800000 7c8f6000   kernel32   (pdb symbols)          c:\symbols\kernel32.pdb\072FF0EB54D24DFAAE9D13885486EE092\kernel32.pdb
7c900000 7c9b2000   ntdll      (pdb symbols)          c:\symbols\ntdll.pdb\6992F4DAF4B144068D78669D6CB5D2072\ntdll.pdb
7c9c0000 7d1d7000   SHELL32    (pdb symbols)          c:\symbols\shell32.pdb\1D082C6DE066485B91BEAD24A3FF1FBC2\shell32.pdb
7e410000 7e4a1000   USER32     (pdb symbols)          c:\symbols\user32.pdb\D18A41B74E7F458CAAAC1847E2D8BF022\user32.pdb
0:000> g
ModLoad: 629c0000 629c9000   C:\WINDOWS\system32\LPK.DLL
ModLoad: 5ad70000 5ada8000   C:\WINDOWS\system32\uxtheme.dll
ModLoad: 59a60000 59b01000   C:\WINDOWS\system32\dbghelp.dll
ModLoad: 01250000 0125f000   C:\Program Files\BillP Studios\WinPatrol\PATROLPRO.DLL
ModLoad: 74720000 7476c000   C:\WINDOWS\system32\MSCTF.dll
ModLoad: 012c0000 012d3000   C:\Program Files\PowerMenu\PowerMenuHook.dll
ModLoad: 77920000 77a13000   C:\WINDOWS\system32\SETUPAPI.dll
eax=00000000 ebx=00000000 ecx=7c800000 edx=77c61ae8 esi=7c90de6e edi=00000001
eip=7c90e514 esp=0012fe24 ebp=0012ff20 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!KiFastSystemCallRet:
7c90e514 c3              ret
0:000> kp
ChildEBP RetAddr  
0012fe20 7c90de7a ntdll!KiFastSystemCallRet
0012fe24 7c81cace ntdll!NtTerminateProcess+0xc
0012ff20 7c81cb26 kernel32!_ExitProcess+0x62
0012ff34 7813179e kernel32!ExitProcess+0x14
0012ff40 78131b66 MOZCRT19!__crtExitProcess(int status = 2014518254)+0x2e [e:\builds\moz2_slave\win32_build\build\obj-firefox\memory\jemalloc\src\crt0dat.c @ 683]
0012ff78 78131bee MOZCRT19!doexit(int code = 1, int quick = 0, int retcaller = 0)+0x116 [e:\builds\moz2_slave\win32_build\build\obj-firefox\memory\jemalloc\src\crt0dat.c @ 596]
0012ff88 00401449 MOZCRT19!exit(int code = 2088857719)+0xe [e:\builds\moz2_slave\win32_build\build\obj-firefox\memory\jemalloc\src\crt0dat.c @ 398]
0012ffc0 7c817077 firefox!__tmainCRTStartup(void)+0x169 [e:\builds\moz2_slave\win32_build\build\obj-firefox\memory\jemalloc\src\crtexe.c @ 605]
0012fff0 00000000 kernel32!BaseProcessStart+0x23
0:000> !analyze -v -f
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   *
*                                                                             *
*******************************************************************************

Event is not an exception


Failure could not be analyzed

.lastevent
Last event: 1004.159c: Exit process 0:1004, code 1
  debugger time: Wed Oct 21 09:11:40.099 2009 (GMT-4)
0:000> lm
start    end        module name
00280000 002ec000   sqlite3    (private pdb symbols)  c:\symbols\sqlite3.pdb\555255959B1B4EF38AD174DEB0E456B81\sqlite3.pdb
002f0000 003d4000   js3250     (private pdb symbols)  c:\symbols\js3250.pdb\5FA11BF4F4724630BF24460CB83EF1A32\js3250.pdb
003e0000 003f8000   smime3     (private pdb symbols)  c:\symbols\smime3.pdb\ECA3CFB3B07142628F2CBC288336A2CD1\smime3.pdb
00400000 004df000   firefox    (private pdb symbols)  c:\symbols\firefox.pdb\15F74A40F5A046A79888A361921B47B12\firefox.pdb
004e0000 00509000   nspr4      (private pdb symbols)  c:\symbols\nspr4.pdb\3B236A5359A24547A3CB7AE1D166D7281\nspr4.pdb
00510000 005aa000   nss3       (private pdb symbols)  c:\symbols\nss3.pdb\6CB5117C8B8746D996DB8D82B493FE9C1\nss3.pdb
005b0000 005c4000   nssutil3   (private pdb symbols)  c:\symbols\nssutil3.pdb\D811CD6175AF48A9B274144F4E0997231\nssutil3.pdb
005d0000 005d7000   plc4       (private pdb symbols)  c:\symbols\plc4.pdb\A381741BEAF54415A5903E34023D07421\plc4.pdb
005e0000 005e7000   plds4      (private pdb symbols)  c:\symbols\plds4.pdb\EEB736169DFA490493CD9C029741A0161\plds4.pdb
005f0000 00610000   ssl3       (private pdb symbols)  c:\symbols\ssl3.pdb\66E3D4CE1EA247348BA4F3D001EAC0721\ssl3.pdb
00610000 00617000   xpcom      (private pdb symbols)  c:\symbols\xpcom.pdb\CEA15912EF5F45039991982B0683F9822\xpcom.pdb
01250000 0125f000   PATROLPRO   (deferred)             
012c0000 012d3000   PowerMenuHook   (deferred)             
10000000 10a5c000   xul        (private pdb symbols)  c:\symbols\xul.pdb\6D7993A52C04439E8F23CBB48F8A7D2E2\xul.pdb
59a60000 59b01000   dbghelp    (deferred)             
5ad70000 5ada8000   uxtheme    (deferred)             
629c0000 629c9000   LPK        (deferred)             
71aa0000 71aa8000   WS2HELP    (pdb symbols)          c:\symbols\ws2help.pdb\6049CF5877C54E2AB512ABC1B4B2E7992\ws2help.pdb
71ab0000 71ac7000   WS2_32     (pdb symbols)          c:\symbols\ws2_32.pdb\A7605F8695A34329B38DDB8421A004CA2\ws2_32.pdb
71ad0000 71ad9000   WSOCK32    (pdb symbols)          c:\symbols\wsock32.pdb\2B38FE8F84144DACB8A4FD07C05E49FC2\wsock32.pdb
73000000 73026000   WINSPOOL   (pdb symbols)          c:\symbols\winspool.pdb\5199B63B39904A05A517CEE5158071522\winspool.pdb
74720000 7476c000   MSCTF      (deferred)             
74d90000 74dfb000   USP10      (pdb symbols)          c:\symbols\usp10.pdb\0F289BC0C9A94139BC1C31EDEDBF52311\usp10.pdb
76380000 76385000   MSIMG32    (pdb symbols)          c:\symbols\msimg32.pdb\D2E18526D8234F4BB5A85DE12E71DE812\msimg32.pdb
76390000 763ad000   IMM32      (pdb symbols)          c:\symbols\imm32.pdb\F7A5B5DB13324153B57AAF340C77EA512\imm32.pdb
763b0000 763f9000   COMDLG32   (pdb symbols)          c:\symbols\comdlg32.pdb\026A6FF770FD4E6186ADBBE96DFFA99C2\comdlg32.pdb
76b40000 76b6d000   WINMM      (pdb symbols)          c:\symbols\winmm.pdb\90FC96D5AD8440A2B14855895BD92ED62\winmm.pdb
77120000 771ab000   OLEAUT32   (pdb symbols)          c:\symbols\oleaut32.pdb\F2A209009B694EFCAD1A6CE9D992EBC12\oleaut32.pdb
773d0000 774d3000   COMCTL32   (pdb symbols)          c:\symbols\MicrosoftWindowsCommon-Controls-6.0.2600.5512-comctl32.pdb\505057971C40416FB39FED1D39BED0571\MicrosoftWindowsCommon-Controls-6.0.2600.5512-comctl32.pdb
774e0000 7761d000   ole32      (pdb symbols)          c:\symbols\ole32.pdb\ED517599D2C14CF19200861833059C142\ole32.pdb
77920000 77a13000   SETUPAPI   (deferred)             
77c00000 77c08000   VERSION    (pdb symbols)          c:\symbols\version.pdb\EA3D1BD3FE65475C8449C8D8B00722962\version.pdb
77c10000 77c68000   msvcrt     (pdb symbols)          c:\symbols\msvcrt.pdb\7BCF30D8C91B4F1B85FA4E55896250111\msvcrt.pdb
77dd0000 77e6b000   ADVAPI32   (pdb symbols)          c:\symbols\advapi32.pdb\F759D3F1C6614313B07C84BC33F02E4D2\advapi32.pdb
77e70000 77f02000   RPCRT4     (pdb symbols)          c:\symbols\rpcrt4.pdb\EC95CBF6C6834027AE389DEBCE5F38332\rpcrt4.pdb
77f10000 77f59000   GDI32      (pdb symbols)          c:\symbols\gdi32.pdb\372C0F0E08FB456EAB7B4CB2B53E27952\gdi32.pdb
77f60000 77fd6000   SHLWAPI    (pdb symbols)          c:\symbols\shlwapi.pdb\8519E3403447478884CFFE7F1A91BAE02\shlwapi.pdb
77fe0000 77ff1000   Secur32    (pdb symbols)          c:\symbols\secur32.pdb\7867B3F28B5C41CE847895E3FC013DC52\secur32.pdb
78130000 781e1000   MOZCRT19   (private pdb symbols)  c:\symbols\mozcrt19.pdb\BA376AEDB4094BDC8508D8E9A1C563121\mozcrt19.pdb
7c800000 7c8f6000   kernel32   (pdb symbols)          c:\symbols\kernel32.pdb\072FF0EB54D24DFAAE9D13885486EE092\kernel32.pdb
7c900000 7c9b2000   ntdll      (pdb symbols)          c:\symbols\ntdll.pdb\6992F4DAF4B144068D78669D6CB5D2072\ntdll.pdb
7c9c0000 7d1d7000   SHELL32    (pdb symbols)          c:\symbols\shell32.pdb\1D082C6DE066485B91BEAD24A3FF1FBC2\shell32.pdb
7e410000 7e4a1000   USER32     (pdb symbols)          c:\symbols\user32.pdb\D18A41B74E7F458CAAAC1847E2D8BF022\user32.pdb
please disable all piugins as test (tools/addon/plugins)
Could it be that another process (malware) on your system sends a terminate/quit signal to FF ?

This looks like something for timeless
Try the hint at https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg#FAQ

Does that capture the exception? If it does I think that document needs changing because ".childdbg 1" doesn't seem to do the job.
(Reporter)

Comment 3

9 years ago
I did carefully follow that suggestion in the WinDbg page, and I ran the latest build I had recompiled today through a number of challenging pages and multiple tabs, and never got an exception. As soon as I exited WinDbg, I opened the same executable from the command line, it tried to load the last 3 tabs I had exited with, and then exited again without any crash file being generated. I can get it to exit every time with 'espn.go.com' in the address bar, which starts loading but exits very quickly. This occurs in safe mode and with an empty profile.
That's annoying. In that case you can setup WinDbg for just in time debugging, i.e. when Firefox crashes the debugger will be automatically be attached. See “Enabling Postmortem Debugging” in the WinDbg documentation.

Thanks for persisting. 

btw, I think there is a way to determine if Firefox crashed or was somehow told to exit: While running it creates a file named parent.lock in the profile directory. If this file is still there when it "exits" then it crashed and you should proceed with trying to get a stack trace. If the file is not there then Firefox probably exited cleanly and you would need to find the cause of that.
(Reporter)

Comment 5

9 years ago
Your right, there are no lock files left. It seems to be making a clean exit, but I'm not sure how to identify what is causing it.
(Reporter)

Comment 6

9 years ago
I've figured this out, I believe. The program causing this was 'Speedbit Video Accelerator'. I disabled it and have not had a crash since. I will update if there is any change in this finding.
(Reporter)

Comment 7

9 years ago
Confirmed, this was NOT firefox, but an external program (SpeedBit Video Accelerator) causing the  exits.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME

Comment 8

9 years ago
So, there are two reasons firefox can quit normally:
1. if there's a firefox already running, then it basically finds the existing instance, sends it a message, and quits
2. something sends firefox a quit request and it processes it and quits

recognizing 1 is handled iirc by .tlist:

 0n4616 windbg.exe
 0n5264 firefox.exe
 0n4100 firefox.exe
You need to log in before you can comment on or make changes to this bug.