Closed Bug 52359 Opened 24 years ago Closed 24 years ago

convert (platform)browserBindings.xul and (platform)editorBindings.xul to XBL

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Future

People

(Reporter: dr, Assigned: hyatt)

References

Details

(Keywords: perf, Whiteboard: [nsbeta3+][pdtp3]WORK IN PROGRESS)

Attachments

(3 files)

Converting the browser and editor bindings to XBL will take advantage of hyatt's
sexy new XBL keybinding code, and will make the crappy
nsXULKeyListenerImpl::HandleEventUsingKeyset code apply to much less stuff (and
therefore less of an immediate issue -- see bug 47395).

There is also a strange symptom in which, although ill-formed XUL reports errors
properly in most cases, ill-formed XUL in these files causes a crash. Converting
the browser and editor bindings to XBL will resolve this.

Doing this will also make fixing bug 47395 easier, because it won't have to deal
with these special cases.
nominating nsbeta3 (see akkana's comments in 47395, on 2000-09-12).
Status: NEW → ASSIGNED
Keywords: nsbeta3
FYI:

timeless sees this in a talkback report somewhere...:
0x023e3900
XULContentSinkImpl::`scalardeleting destructor'
XULContentSinkImpl::Release
  [d:\builds\seamonkey\mozilla\rdf\content\src\nsXULContentSink.cpp,line510]
nsCOMPtr_base::~nsCOMPtr_base
  [d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp,line50]
nsXULKeyListenerImpl::LoadKeyBindingDocument
  [d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp,line1331]
nsXULKeyListenerImpl::GetKeyBindingDocument
  [d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp,line1193]
nsXULKeyListenerImpl::DoKey
  [d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp,line680]
nsXULKeyListenerImpl::KeyDown
  [d:\builds\seamonkey\mozilla\rdf\content\src\nsXULKeyListener.cpp,line568]

This is that strange symptom mentioned above, about crashing browserBindings.
Don't bother filing a new bug -- it'll go away when they get XBL'ed.
Blocks: 50440
nsbeta3+, p2 for m18, since it saves work on bug 47395, and reduces the
complexity and risk, as well as adding some incremental performance
enhancements.  Also, it is needed for embedding.  This is contingent on akkana
being able to convert the xul files themselves.
Assignee: dr → hyatt
Status: ASSIGNED → NEW
Keywords: perf
Priority: P3 → P2
Whiteboard: [nsbeta3+] if akkana can do file conversion
Target Milestone: --- → M18
I can convert the XUL files to XBL. 
PDT not sure what the problem is with this. Bug 47395 is not an obvious stopper
to us, so this bug isn't obvious either. Please explain what bad thing happens
to users if we don't fix this, or this is nsbeta3-
Assignee: hyatt → dr
Whiteboard: [nsbeta3+] if akkana can do file conversion → [nsbeta3+]WORK IN PROGRESS
This is necessary for a bunch of reasons: it fixes a crash, it drastically
improves linux performance, it helps embedding, etc.

Work is in progress (will be finished around noon, 9-21) to do this conversion,
as part of an XPToolkit and editor team push to fix linux editor performance.
See 48758.
*** Bug 24645 has been marked as a duplicate of this bug. ***
Blocks: 48758
I've moved editorBindings.xul into htmlBindings.xml, and
unix/platformEditorBindings.xml into unix/platformHTMLBindings.xml -- will
attach.  Anthony has graciously volunteered to work on the others, cc'ing him.
PDT: note that at least one PDTP1 bug has cited this as a dependency.
damnit how do i attach a zip file?

anthony
dependent bug is 48758.
per pdt, p3 on its own merits, but we understand if this gets checked in with 48758.
Priority: P2 → P3
Whiteboard: [nsbeta3+]WORK IN PROGRESS → [nsbeta3+][pdtp3]WORK IN PROGRESS
Target Milestone: M18 → Future
collecting these.
Assignee: dr → hyatt
Fixed.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
rubberstamp vrfy.
Status: RESOLVED → VERIFIED
Blocks: 27661
Component: Keyboard: Navigation → User events and focus handling
You need to log in before you can comment on or make changes to this bug.