[he] Thunderbird 3 in-product pages localization

RESOLVED FIXED

Status

RESOLVED FIXED
9 years ago
2 months ago

People

(Reporter: pascalc, Assigned: tomer)

Tracking

Details

(URL)

You will find in bug #523583 instructions about the 2 in-product pages to be localized for the Thundebird 3 release planned this quarter.

The files are on the SVN repository in your locale folder, preferably commit
directly to SVN and once done, inform in this bug.

Alternatively, you can attach the files to this bug (either individually or as
a zip archive).

If you attach individual .html files, please attach them with the plain/text
Mime format.

News and instructions affecting all locales will be posted and updated if
necessary in the master bug (bug #523583)

Thanks!!
(Assignee)

Updated

9 years ago
Assignee: nobody → tomer
(Assignee)

Comment 1

9 years ago
Done r54223.

Is it possible to place a link to the local community like how we does with the Firefox landing page?
Personnally I am in favour of it but Rafael should decide on it since he is the landlord for mozillamessaging ;) CCing him
Yes, it's possible to add a link to the local community.  We can use this bug and just let me review when you have it in.
(Assignee)

Comment 4

9 years ago
http://he.trunk.mozillamessaging.com/he/thunderbird/3.0/start/index.html
http://he.trunk.mozillamessaging.com/he/thunderbird/3.0/whatsnew/index.html

I would be happy to close this bug, but sadly it is *impossible* until we have better RTL stylesheet. Please take a look on the start page (linked above) - The background image should not be placed behind the text, making it hard to be read. 


(In reply to comment #3)
> Yes, it's possible to add a link to the local community.  We can use this bug
> and just let me review when you have it in.
Since we have added link on bug 526112, I think we can live without a link, while I prefer to get more localized content available, such as a visible link to the speller dictionary and to the bidiui addon (possible to get these shown only if the user doesn't have these addons installed). A paragraph welcoming the user to visit the local community is also can be nice.
(Assignee)

Comment 5

9 years ago
Okay, It seems to be an issue caused by the background image. While I can flip the image to make it better, we can't use this solution as the Thunderbird logo is hardcoded on the image and we don't want to get it flipped as well. I need the source images in order to place the right logo on the flipped images.

$ wget http://he.trunk.mozillamessaging.com/img/thunderbird/start/feature-background.jpg
$ convert feature-background.jpg -flop feature-background-rtl.jpg
(Assignee)

Comment 6

9 years ago
Also, we need to make sure the non-rtl background image won't get loaded on the RTL pages (ar, fa, he) because this is an extra 75kb per page view which make the loading way slower.
I changes the margin for rtl pages so the background image is no longer a problem, I think it looks good (tested on Hebrew and Arabic).

I think you can use the community link to link to your local community 
site, is that ok for you?
(Assignee)

Comment 8

9 years ago
The new design seems better to me. 

As for the communnity link, I think we can live well with the link on the landing page, and it might be better place for linking than this place.
ok, marking fixed then, thanks
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: Websites → www.mozilla.org

Updated

2 months ago
Product: www.mozilla.org → www.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.