Delete of IMAP folder with unread mail causes flood of popups

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: jochen.mozilla, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091020 Shredder/3.0pre

When deleting an IMAP folder while TB is downloading headers for that folder, TB will try to access the folder after it's deleted and will show one popup for each message in the folder.

Reproducible: Always

Steps to Reproduce:
1. Have an IMAP folder with new, unread messages
2. Click the folder
3. While TB is still downloading the headers, delete the folder

Actual Results:  
After TB finishes downloading the headers, it will pop up an error message saying "The current command did not succeed. The mail server responded:Mailbox doesn't exist: <name of folder>". Closing this popup brings up another, identical one. This happens once for each message in the folder.

Expected Results:  
TB should not try to access the folder after it got deleted, and shouldn't show any popups.
Component: Mail Window Front End → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.imap
Version: unspecified → Trunk
Jochen , anything in the Tools -> Error console when this happens ?
I couldn't reproduce with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.5pre) Gecko/20091020 Shredder/3.0pre what I did is slighly different :

1) created a new account
2) while thunderbird was downloading I deleted a folder.
3) No popups
(Reporter)

Comment 3

9 years ago
On #1, I'll check next time it happens. I don't have any folder with enough messages at the moment.

On #2, did you make sure that TB was actively downloading the headers for the specific folder you deleted?  It's not enough for TB to be downloading something, it has to be the headers for the folder you're deleting.
(In reply to comment #3)
 
> On #2, did you make sure that TB was actively downloading the headers for the
> specific folder you deleted?  It's not enough for TB to be downloading
> something, it has to be the headers for the folder you're deleting.

No, so it's per folder.
(Reporter)

Comment 5

9 years ago
On #1: error console remains empty
(Reporter)

Comment 6

9 years ago
And it appears I may be slightly off in the specifics. It looks like the problem is when it's downloading the actual messages, not the headers. So this probably only happens when "Keep messages for this account on this computer" is checked.

So an additional sequence that triggers it is:

1) click folder with a bunch of new mesages
2) TB downloads headers
3) TB starts downloading messages in the background
4) Delete folder
5) Get one popup for each message not yet downloaded
(Reporter)

Comment 7

9 years ago
Some more details from when it just happened again, this time back to the original delete-while-downloading-headers variety:

1) click folder
2) TB starts downloading headers
3) Delete folder
** 4) TB keeps downloading headers in background; progress messages (x of y headers downloaded) show up in the status bar
** 5) TB briefly shows "deleted <folder>" in status bar
** 6) TB shows "opening <folder>" in status bar
** 7) TB shows "Downloading x of y in <folder>"
** 8) popup

Comment 8

8 years ago
Jochen, does this reproduce with version 3.1?
(Reporter)

Comment 9

8 years ago
No longer a significant issue.

Using: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.15) Gecko/20110303 Thunderbird/3.1.9

The error message has been moved from a popup to a non-modal notification in the bottom right-hand corner. I _think_ it now only shows it once per folder, but either way since it now goes away automatically it does not impede normal use.

Feel free to mark this fixed.

Comment 10

7 years ago
Jochen, thanks for the update.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.