Deleted entries in PAB shows up in mailing list.

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
P2
normal
VERIFIED WORKSFORME
18 years ago
14 years ago

People

(Reporter: Suresh, Assigned: Cavin Song)

Tracking

({regression})

Trunk
mozilla1.0.1
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
steps:
1. Create a new mailing list A with entries, say e1 and e2. Assuming e1 and e2
doesn't exist in the PAB, it is added to it. 
2. Now delete e2 from PAB. => it should also be deleted from A. If you select
the mailing list A, it doesn't show up. 
3. Select it in PAB. Click Edit. you will see that the deleted address e2 shows
up in the mailing list.  Bad.
4. Compose and send a msg to this mailing list A. It is also sent to e2. Again
Bad. 

Build and platform:
Today's Mac and Linux commercial build. Expecting the same on Win32.
(Reporter)

Comment 1

18 years ago
Nominating for nsbeta3. Coz, A mail could be sent to a person that I deleted
from a mailing list. 
Keywords: nsbeta3

Updated

18 years ago
QA Contact: esther → suresh
(Reporter)

Comment 2

18 years ago
Adding Candice to the cc list.

Comment 3

18 years ago
reassign to myself
Assignee: putterman → chuang

Comment 4

18 years ago
I'm a little confused by step 2 and 3. Is step 2 means you click mail llist A in 
the left pane, you didn't see e2 in the right pane?  Step 3 is you click on A 
and you see e2 in the mailing list dialog.
(Reporter)

Comment 5

18 years ago
Let me be more clear in step 2 and step 3.

2. Select PAB in the Left pane(LP) (NOT the mailing list). You will see all the 
cards and mailing list in the right pane (RP) that are in PAB. Now delete a card 
e2 from PAB (i.e from RP) => e2's in all the mailing list must be deleted. So 
Mailing list A must be left with only one entry e1. 

3. (Select the mailing list A in the LP. You will see only one entry e1 in the 
RP. Good!! ) Now select PAB in the LP. Select list A in the RP. Click Edit to 
bring up mailing list A. You will see the deleted entry e2 in the mailing list 
A.  If you send a msg to A, it is also sent to e2. Not good..

Comment 6

18 years ago
This is a regression, it was wroking before.  I think I have a fix.
Status: NEW → ASSIGNED
Keywords: regression

Comment 7

18 years ago
nsbeta3+, P2.  It's critical that users actually send mail ONLY to the 
recipients they intended, no more, no less.
Priority: P3 → P2
Target Milestone: --- → M18

Comment 8

18 years ago
OK, marking nsbeta3+ now...
Whiteboard: [nsbeta3+]

Updated

18 years ago
Whiteboard: [nsbeta3+] → [nsbeta3+]Fix in hand

Comment 9

18 years ago
Fix checked in last night.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 10

18 years ago
I'm reopening this bug.  This is what I see in today's windows and 
linux commercial build.

First let me explain the lists and cards in my PAB. I have two Mailing list in 
my PAB. 
List A: containing entries e1 and e2.
List B: containing entries e1 and e3. (Note that e1 is in both lists).

1. Select PAB in the left pane (LP). Select the card e1 in the right pane (RP). 
Delete it. => it should be removed from the mailing lists that has this card (In 
this case e1 should be deleted from both the mailing list A and B).
2. Select the mailing list A in the RP. Click Edit. Yes, you will see the 
deleted card e1 in the list. Click ok. After you click OK, somehow the deleted 
card email field shows up in the RP. (Note that the Name field is not displayed)
And both the lists still contains this Card, e1. 

3. If I send a mail to lists A/B, it is also deliverd to e1. Not good. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

18 years ago
PDT agrees P2
Whiteboard: [nsbeta3+]Fix in hand → [nsbeta3+][PDTP2]

Comment 12

18 years ago
If this doesn't make beta3, we want to get it for rtm.
Keywords: rtm

Comment 13

18 years ago
I agree.  To reproduce this bug, you have to add an existing card to the mailing 
list.  If you add a non-existing email address from mailing list dialog, this 
bug won't happen.  This increase the chance for user to hit this bug.

I'm working on the fix,  it won't be able to make it for code review.  But I 
should have the fix tomorrow.

Updated

18 years ago
Whiteboard: [nsbeta3+][PDTP2] → [nsbeta3+][PDTP2] fix in hand

Updated

18 years ago
Whiteboard: [nsbeta3+][PDTP2] fix in hand → [nsbeta3+][PDTP2][rtm+] fix in hand

Comment 14

18 years ago
Not holding PR3 for this. Marking nsbeta3- 
Whiteboard: [nsbeta3+][PDTP2][rtm+] fix in hand → [nsbeta3-][PDTP2][rtm+] fix in hand

Comment 15

18 years ago
Created attachment 15734 [details] [diff] [review]
Patch for the fix,  need code review.

Comment 16

18 years ago
Scott, can you review it and cc alecf, mscott for super review.  Email me if you
need more info on the fix.

Comment 17

18 years ago
sr=alecf

Comment 18

18 years ago
PDT marking [rtm++]
Whiteboard: [nsbeta3-][PDTP2][rtm+] fix in hand → [nsbeta3-][PDTP2][rtm++] fix in hand

Comment 19

18 years ago
Fix checked in both branch and trunk.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 20

18 years ago
Verified using today's Branch builds on all platforms.
Keywords: vtrunk

Updated

18 years ago
QA Contact: suresh → pmock

Updated

18 years ago
QA Contact: pmock → fenella

Comment 21

18 years ago
Cannot verify this bug until bug 68874 is fixed.

Comment 22

17 years ago
Linux (2001-04-16-10 trunk)
Win32 (2001-04-16-06 trunk)
Mac (2001-04-16-04 trunk)
This bug comes back. Re-open it.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

17 years ago
QA Contact: fenella → nbaca

Comment 23

17 years ago
reassigning to cavin
Assignee: chuang → cavin
Status: REOPENED → NEW

Comment 24

17 years ago
Removing [PDT] grafitti.
Whiteboard: [nsbeta3-][PDTP2][rtm++] fix in hand → fix in hand

Comment 25

17 years ago
Maybe the target milestone should be changed on this one...

Comment 26

17 years ago
Suresh or nbaca, are you still able to reproduce this?
Keywords: nsbeta3, nsrtm
Whiteboard: fix in hand
Target Milestone: M18 → mozilla1.0.1
(Reporter)

Comment 27

17 years ago
I couldn't duplicate this bug using today's trunk commercial build on win2k.

Comment 28

17 years ago
nbaca, if you can't reproduce this either, could we mark this WFM?

Comment 29

17 years ago
Trunk build 2001-11-21: WinMe
Marking Worksforme.
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 30

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.