Star Icon used in Message list pane is too big

RESOLVED FIXED in Thunderbird 3.0rc1

Status

Thunderbird
Message Reader UI
P3
normal
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Valery Kondakoff, Assigned: andreasn)

Tracking

({polish})

Trunk
Thunderbird 3.0rc1
All
Windows 7
polish
Bug Flags:
blocking-thunderbird3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [no l10n impact])

Attachments

(4 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.5pre) Gecko/20091021 Shredder/3.0pre

Star Icon used in Message list pane is too big and does not fit in the column (I can not resize the column  width by draggin it's borders with mouse). See the screenshot.

I think the size of the star in message list columns should match the size of the star in the column header.

Reproducible: Always
(Reporter)

Comment 1

9 years ago
Created attachment 407739 [details]
Screenshot of message list pane with the big Star icon
I don't agree.
Component: General → Message Reader UI
QA Contact: general → message-reader
(Assignee)

Updated

9 years ago
Assignee: nobody → nisses.mail
(Reporter)

Comment 3

9 years ago
The Star icon should fit into the column width. Thus the icon size should be
reduced, or there should be a way to change the width of the column.
set to New because Andreas has assigned to him
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

9 years ago
I just mentioned the Star icon, because right now it does not fit into column width. But take a look at the other icons (attach and spam). Attach icon size matches the size of column header icon. Spam and Star icons does not match the size of columns headers icons.

This looks rather ugly. Just made all the icons equal size and made it fit to the column size.
(Reporter)

Comment 6

9 years ago
Created attachment 407974 [details]
Spam, Star and Attach icons of different size

Updated

9 years ago
Flags: blocking-thunderbird3?
Keywords: polish
the spam icon looks fine to me but somehow our star icon has lost the space it needed.  Did this one not get changed to the smaller star icon?  marking as blocking polish for andreas
Flags: blocking-thunderbird3? → blocking-thunderbird3+
Created attachment 408036 [details]
Windows Media Center Royale Theme

I know that isn't this the right place (but I admit about theme refactoring I did not understand much: e.g bug #506011 is closed but has various issue etc) it seems that using the royale theme (the default theme in Windows Media Center, I use an version for Windows XP) the icon on message list are misalligned as in attached sceenshot. 
But probably it's better open a new bug, but I'm not on Windows Media Center... we have a very Windows Media Center user that can test this?

Updated

9 years ago
Whiteboard: [no l10n impact]
(Assignee)

Comment 9

9 years ago
Created attachment 408357 [details] [diff] [review]
fix for linux, xp and vista
Attachment #408357 - Flags: ui-review?(clarkbw)
Attachment #408357 - Flags: review?(philringnalda)
Whiteboard: [no l10n impact] → [no l10n impact][needs review philor,clarkbw]

Comment 10

9 years ago
It's curious that the screenshot in attachment 381857 [details] of bug 496642 clearly shows a wider star column. Was the size intentionally decreased since summer?
Attachment #408357 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 408357 [details] [diff] [review]
fix for linux, xp and vista

Tried this on Vista so far and it looks good.  Will do a check on Linux later but from looking at the files I think it will be very similar.
Priority: -- → P3
Hardware: x86 → All
Whiteboard: [no l10n impact][needs review philor,clarkbw] → [no l10n impact][needs review philor]
Target Milestone: --- → Thunderbird 3.0rc1
Version: unspecified → Trunk
Comment on attachment 408357 [details] [diff] [review]
fix for linux, xp and vista

Linux is fine, and my XP build finally finished and is fine too.
Attachment #408357 - Flags: review?(philringnalda) → review+
Keywords: checkin-needed
Whiteboard: [no l10n impact][needs review philor] → [no l10n impact]
Checked in:
http://hg.mozilla.org/comm-central/rev/a3da2f2e37ac
http://hg.mozilla.org/releases/comm-1.9.1/rev/3d923f9323f4
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.