Closed Bug 523899 Opened 14 years ago Closed 9 years ago

Username is reset for saved passwords

Categories

(Toolkit :: Password Manager, defect)

x86
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 499649

People

(Reporter: fry.kun, Unassigned)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.3) Gecko/20090909 Fedora/3.5.3-1.fc11 Firefox/3.5.3

I have an account with sourceforge.net. At some point I saved my password in Firefox while logging in, but the username was entered starting with an uppercase letter (I believe that was my input).
Sourceforge changed their login script to error out on uppercase letters in username, so when I tried to log in just now, it errored out.
Problem is, I've manually changed the username to all lowercase but every time the username textbox lost focus, the old Uppercased username replaced it.
I had to remove the saved username/password from password manager and re-enter it with lowercase manually.

Reproducible: Always

Steps to Reproduce:
1. Log in & save a username/password for some page, enter the username starting with an uppercase character
2. Try to log in again with same username but change the uppercase character to lowercase
3. Un-focus the username textbox -- username is replaced with saved version
This one should be marked as a duplicate of bug #499649.
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-15]
Yes, this is still happening in 3.6.13 with fresh profile and with 4 beta 9 with fresh profile.
To reproduce:
* go to https://sourceforge.net/account/login.php
* try to log in using login: Test password: test and tell Firefox to remember the password
* next time you load the login page, try changing login "Test" to "test" - it will revert as soon as the textbox loses focus
Whiteboard: [CLOSEME 2011-2-15]
Version: unspecified → Trunk
Blocks: 533065
No longer blocks: 533065
Component: General → Password Manager
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.