page scrolling doesn't stop on cursor key release

VERIFIED DUPLICATE of bug 25054

Status

()

Core
Event Handling
P3
normal
VERIFIED DUPLICATE of bug 25054
18 years ago
18 years ago

People

(Reporter: Andreas Franke (gone), Assigned: joki (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (X11; I; Linux 2.2.10 i686)
BuildID:    2000091212

In the last weeks a feature known from 4.x has been added to mozilla which
enhances usability when reading long texts:
When I hold down the mouse button on down-arrow of the vertical scrollbar, the
page is scrolled down line-by-line, and when the mouse button is released, the
scrolling stops immediately.
In 4.x, the same is true for scrolling with the cursor keys: once the
cursor-down key is released, the scrolling stops. Mozilla does not support this
feature for cursor keys, but it does this right for the scrollbar downarrow.


Reproducible: Always
Steps to Reproduce:
1. load e.g. http://www.mozilla.org/projects/seamonkey/release-notes/

A. The feature works with the scrollbar down-arrow:
   1. press & hold down left mouse button on the down-arrow of the 
      vertical scrollbar
   2. observe that the page is scrolling down line by line
   3. release the mouse button
   4. observe that the scrolling stops immediately

B. The feature does not work with the cursor-down key:
   0. click in the content area
   1. press and hold down the curser-down key
   2. observe that the page is scrolling down line by line
   3. release the cursor-down key
   4. observe that the scrolling does NOT stop	

Actual Results:  The scrolling continues for a long time. After that you have to
scroll back again to find the place where you stopped reading.

Expected Results:  The scrolling should stop immediately. The behaviour should
be the same as if the scrollbar's down-arrow had been used with the mouse.		

I have looked through the existing bugs with "scroll" in the summary, and the
existing bugs in the "Event Handling" component, but I couldn't find this. 
I can only test this on linux. Would be nice to know about the situation on Win.

Blake, do you know where this should go? Who should be on cc? Can you help route
this to the right person? Maybe there is a simple fix?
(Reporter)

Updated

18 years ago
Keywords: 4xp

Comment 1

18 years ago
cc'ing some people
(Assignee)

Comment 2

18 years ago
On WinNT on a P3-450 I don't really see this.  There is perhaps a single 
line scroll event which slips in after the key release but that's it.  Seems 
likely to be an event queuing issue on Linux where we're just building up too 
many key events.  Possibly would occur on slower Windows machines or Macs as 
well, I'm not sure.  Either way not a stop ship at this point.  I'm going to 
accept this one but mark it future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 3

18 years ago
Updating QA Contact.
QA Contact: janc → lorca
(Reporter)

Comment 4

18 years ago
This bug is a duplicate of bug 31606 ``scrolling by keys should stop immediately
when key lifted'' which is a verified duplicate of bug 25054 ``Arrow-key
scrolling slow and key-presses "queue up" which is annoying'' which has been
marked verified worksforme. However, I'd like you to keep one of these bugs open
since the problem still exists.

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 5

18 years ago
Yup.  Duplicate.


*** This bug has been marked as a duplicate of 25054 ***
(Reporter)

Comment 6

18 years ago
Have you actually read my comment? Will you reopen bug 25054 instead? Why is
that bug is a better representative for the problem than this one?

Comment 7

18 years ago
1) Yes, I read your comments.  2) I'm not seeing either problem (keeping the 
arrow key down, or pressing it many times repeatedly). 3) This bug *is* a 
duplicate of the bug mentioned above.  4) Generally the bug that is marked as 
duplicate has less information than the "original".  If there is no significant 
difference in content/information, the one written first is considered original.  
That being said, if you like you may reopen the other bug, put this information 
in, and bring it to light again.  As I said though, I tested it in build 11-04-09 
in Linux 6.2 and saw no problems with either keeping the key down or pressing it 
repeatedly.

Have you seen this with a recent build?
(Reporter)

Comment 8

18 years ago
Ok, verified duplicate. Yes, the problem still exists on 11/1 builds, both
branch and trunk, on SuSE 6.2 (linux 2.2.10). Will reopen bug 25054 then.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.